rearrange includes to always be: internal GR, external, with GR.
[debian/gnuradio] / usrp / host / lib / Makefile.am
index 4b889993b753ba14b49f27583a1dbbaa7edd0118..b8b60fa98407ab4615ca24e0ce5b7ecacbd10c11 100644 (file)
@@ -1,22 +1,22 @@
 #
 #  USRP - Universal Software Radio Peripheral
-# 
-#  Copyright (C) 2003,2004,2006,2007,2008,2009 Free Software Foundation, Inc.
-# 
+#
+#  Copyright (C) 2003,2004,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
+#
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 #  the Free Software Foundation; either version 3 of the License, or
 #  (at your option) any later version.
-# 
+#
 #  This program is distributed in the hope that it will be useful,
 #  but WITHOUT ANY WARRANTY; without even the implied warranty of
 #  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 #  GNU General Public License for more details.
-# 
+#
 #  You should have received a copy of the GNU General Public License
 #  along with this program; if not, write to the Free Software
 #  Foundation, Inc., 51 Franklin Street, Boston, MA  02110-1301  USA
-# 
+#
 
 include $(top_srcdir)/Makefile.common
 
@@ -24,17 +24,17 @@ common_INCLUDES = $(USRP_INCLUDES) $(USB_INCLUDES)
 
 lib_LTLIBRARIES = libusrp.la
 
-libusrp_la_common_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0 $(BOOST_LDFLAGS)
+libusrp_la_common_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS) $(BOOST_LDFLAGS)
 
 libusrp_la_common_LIBADD =             \
        $(USB_LIBS)                     \
        $(BOOST_THREAD_LIB)             \
        ../misc/libmisc.la
 
-# darwin fusb requires omnithreads
+# darwin fusb requires gruel (for threading)
 if FUSB_TECH_darwin
-AM_CPPFLAGS = $(common_INCLUDES) $(OMNITHREAD_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
-libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(OMNITHREAD_LA)
+AM_CPPFLAGS = $(GRUEL_INCLUDES) $(common_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
+libusrp_la_LIBADD = $(libusrp_la_common_LIBADD) $(GRUEL_LA)
 libusrp_la_LDFLAGS = $(libusrp_la_common_LDFLAGS) -framework CoreFoundation
 else
 AM_CPPFLAGS = $(common_INCLUDES) $(BOOST_CPPFLAGS) $(WITH_INCLUDES)
@@ -61,8 +61,7 @@ BUILT_SOURCES += usrp_dbid.cc \
 generic_CODE =                                 \
        fusb_generic.cc                 \
        fusb_sysconfig_generic.cc       \
-       usrp_prims_libusb0.cc           \
-       usrp_basic_libusb0.cc
+       usrp_prims_libusb0.cc           
 
 darwin_CODE =                          \
        fusb_darwin.cc                  \
@@ -71,35 +70,29 @@ darwin_CODE =                               \
        circular_buffer.h               \
        circular_linked_list.h          \
        darwin_libusb.h                 \
-       mld_threads.h                   \
-       usrp_prims_libusb0.cc           \
-       usrp_basic_libusb0.cc
+       usrp_prims_libusb0.cc           
 
 
 win32_CODE =                           \
        fusb_win32.cc                   \
        fusb_sysconfig_win32.cc         \
-       usrp_prims_libusb0.cc           \
-       usrp_basic_libusb0.cc
+       usrp_prims_libusb0.cc           
 
 
 linux_CODE =                           \
        fusb_linux.cc                   \
        fusb_sysconfig_linux.cc         \
-       usrp_prims_libusb0.cc           \
-       usrp_basic_libusb0.cc
+       usrp_prims_libusb0.cc           
 
 ra_wb_CODE =                           \
        fusb_ra_wb.cc                   \
        fusb_sysconfig_ra_wb.cc         \
-       usrp_prims_libusb0.cc           \
-       usrp_basic_libusb0.cc
+       usrp_prims_libusb0.cc           
 
 libusb1_CODE =                         \
        fusb_libusb1.cc                 \
        fusb_sysconfig_libusb1.cc       \
-       usrp_prims_libusb1.cc           \
-       usrp_basic_libusb1.cc
+       usrp_prims_libusb1.cc           
 
 #
 # include each <foo>_CODE entry here...
@@ -116,15 +109,18 @@ EXTRA_libusrp_la_SOURCES =                \
 libusrp_la_common_SOURCES =            \
        fusb.cc                         \
        md5.c                           \
-       usrp_basic_common.cc            \
+       usrp_basic.cc                   \
        usrp_config.cc                  \
        usrp_dbid.cc                    \
        usrp_local_sighandler.cc        \
        usrp_prims_common.cc            \
        usrp_standard.cc                \
+       db_wbxng_adf4350.cc             \
+       db_wbxng_adf4350_regs.cc        \
        db_boards.cc                    \
        db_base.cc                      \
        db_basic.cc                     \
+       db_bitshark_rx.cc               \
        db_tv_rx.cc                     \
        db_tv_rx_mimo.cc                \
        db_flexrf.cc                    \
@@ -166,6 +162,8 @@ noinst_HEADERS =                    \
        db_base_impl.h                  \
        db_boards.h                     \
        db_util.h                       \
+       db_wbxng_adf4350.h              \
+       db_wbxng_adf4350_regs.h         \
        fusb.h                          \
        fusb_darwin.h                   \
        fusb_generic.h                  \