Merged r7478:7608 from michaelld/t186 into trunk. Adds ability to compile GNU Radio...
[debian/gnuradio] / usrp / host / apps / Makefile.am
index e0f5b8cf4c18569f6fe34b7f4fa5fb0a641aa847..cc93d0d3c3cbf3fe345cb1ae613962545911eca0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2003,2006 Free Software Foundation, Inc.
+# Copyright 2003,2006,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES =     \
-       $(DEFINES) $(OMNITHREAD_INCLUDES) $(PMT_INCLUDES) $(MBLOCK_INCLUDES) \
-       $(USRP_INCLUDES) $(BOOST_CFLAGS) $(CPPUNIT_INCLUDES)
-
+INCLUDES = $(USRP_INCLUDES) $(BOOST_CFLAGS) $(CPPUNIT_INCLUDES) \
+          $(WITH_INCLUDES)
 
 bin_PROGRAMS =                         \
        usrper                          \
@@ -32,20 +30,11 @@ bin_PROGRAMS =                              \
 
 noinst_PROGRAMS =                      \
        check_order_quickly             \
-       test_usrp_inband_cs             \
-       test_usrp_inband_ping           \
-       test_usrp_inband_registers      \
-       test_usrp_inband_rx             \
-       test_usrp_inband_tx             \
-       test_usrp_inband_timestamps     \
        test_usrp_standard_rx           \
-       test_usrp_standard_tx           \
-       read_packets
+       test_usrp_standard_tx           
 
 noinst_HEADERS =                       \
-       time_stuff.h                    \
-       ui_nco.h                        \
-       ui_sincos.h                     
+       time_stuff.h                    
 
 noinst_PYTHON =                                \
        burn-db-eeprom                  \
@@ -65,24 +54,3 @@ usrper_LDADD                         = $(USRP_LA)
 
 usrp_cal_dc_offset_SOURCES     = usrp_cal_dc_offset.cc
 usrp_cal_dc_offset_LDADD       = $(USRP_LA)
-
-test_usrp_inband_cs_SOURCES    = test_usrp_inband_cs.cc time_stuff.c ui_sincos.c
-test_usrp_inband_cs_LDADD      = $(USRP_LA)
-
-test_usrp_inband_ping_SOURCES  = test_usrp_inband_ping.cc time_stuff.c
-test_usrp_inband_ping_LDADD    = $(USRP_LA)
-
-test_usrp_inband_tx_SOURCES    = test_usrp_inband_tx.cc time_stuff.c ui_sincos.c
-test_usrp_inband_tx_LDADD      = $(USRP_LA)
-
-test_usrp_inband_timestamps_SOURCES    = test_usrp_inband_timestamps.cc time_stuff.c ui_sincos.c
-test_usrp_inband_timestamps_LDADD      = $(USRP_LA)
-
-test_usrp_inband_registers_SOURCES     = test_usrp_inband_registers.cc time_stuff.c ui_sincos.c
-test_usrp_inband_registers_LDADD       = $(USRP_LA)
-
-test_usrp_inband_rx_SOURCES    = test_usrp_inband_rx.cc time_stuff.c ui_sincos.c
-test_usrp_inband_rx_LDADD      = $(USRP_LA)
-
-read_packets_SOURCES = read_packets.cc
-read_packets_LDADD = $(USRP_LA)