Merge branch 'prefix' of git://gnuradio.org/jabele
[debian/gnuradio] / usrp / firmware / src / usrp2 / Makefile.am
index de7164b4b0ede181e5bb36458c975060771c9d92..4402cd6365901e4cba936a26f7d3d41448e63b42 100644 (file)
@@ -5,7 +5,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -54,7 +54,7 @@ EXTRA_DIST =                  \
 
 
 DEFINES=-DHAVE_USRP2
-INCLUDES=-I$(top_srcdir)/usrp/firmware/include \
+FW_INCLUDES=-I$(top_srcdir)/usrp/firmware/include \
          -I$(top_srcdir)/usrp/firmware/src/usrp2 \
         -I$(top_srcdir)/usrp/firmware/src/common \
         -I$(top_builddir)/usrp/firmware/src/common
@@ -91,7 +91,7 @@ noinst_SCRIPTS =              \
 
 
 .c.rel:
-       $(XCC) $(INCLUDES) $(DEFINES) \
+       $(XCC) $(FW_INCLUDES) $(DEFINES) \
                -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
 
 .a51.rel:
@@ -108,11 +108,11 @@ eeprom_boot.ihx: $(EEPROM_BOOT_OBJS) $(LIBDEP)
        $(XCC) $(LINKOPTS) -o $@ $(EEPROM_BOOT_OBJS)
 
 burn-usrp2-eeprom: eeprom_boot.ihx
-       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r2 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -p$(prefix) -r2 eeprom_boot.ihx > $@
        chmod +x $@
 
 burn-usrp4-eeprom: eeprom_boot.ihx
-       $(PYTHON) $(srcdir)/../common/build_eeprom.py -r4 eeprom_boot.ihx > $@
+       $(PYTHON) $(srcdir)/../common/build_eeprom.py -p$(prefix) -r4 eeprom_boot.ihx > $@
        chmod +x $@