Imported Upstream version 2.6.1
[debian/amanda] / recover-src / Makefile.am
index 364f6dedbc6b784b8e52cab24657060f6fff4f35..ec25b9e30be179e92d3a16b47ad04cce13e51500 100644 (file)
@@ -1,18 +1,25 @@
 # Makefile for Amanda file recovery programs.
 
+include $(top_srcdir)/config/automake/vars.am
+include $(top_srcdir)/config/automake/installperms.am
+include $(top_srcdir)/config/automake/precompile.am
+
 INCLUDES =     -I$(top_builddir)/common-src \
                -I$(top_srcdir)/common-src   \
                -I$(top_srcdir)/client-src   \
-               -I$(top_srcdir)/tape-src
+               -I$(top_srcdir)/amandad-src   \
+               -I$(top_srcdir)/gnulib
+
+AM_CFLAGS = $(AMANDA_WARNING_CFLAGS)
+AM_LDFLAGS = $(AMANDA_STATIC_LDFLAGS)
+
+LINT=$(AMLINT)
+LINTFLAGS=$(AMLINTFLAGS)
 
 LIB_EXTENSION = la
 
 sbin_PROGRAMS =                amrecover
 
-if WANT_RUNTIME_PSEUDO_RELOC
-AM_LDFLAGS = -Wl,-enable-runtime-pseudo-reloc
-endif
-
 ###
 # Because libamanda includes routines (e.g. regex) provided by some system
 # libraries, and because of the way libtool sets up the command line, we
@@ -22,34 +29,45 @@ endif
 
 LDADD = ../common-src/libamanda.$(LIB_EXTENSION) \
        @LEXLIB@ \
-       ../client-src/libamclient.$(LIB_EXTENSION)
-if WANT_SERVER
-LDADD += ../tape-src/libamtape.$(LIB_EXTENSION)
-endif
-LDADD += ../common-src/libamanda.$(LIB_EXTENSION) \
-       $(READLINE_LIBS)
-
-amrecover_SOURCES =    amrecover.c                                     \
+       $(READLINE_LIBS) \
+       ../client-src/libamclient.$(LIB_EXTENSION) \
+       ../common-src/libamanda.$(LIB_EXTENSION)
+
+amrecover_CSRC =       amrecover.c                                     \
                        display_commands.c              extract_list.c  \
-                       help.c                          set_commands.c  \
-                       uparse.y                        uscan.l
+                       help.c                          set_commands.c
+
+amrecover_SOURCES =    $(amrecover_CSRC)       uparse.y        uscan.l
 
 noinst_HEADERS =       amrecover.h uparse.h
 
 AM_YFLAGS =            -d
 
-install-exec-hook:
-       @list="$(sbin_PROGRAMS)"; \
-       for p in $$list; do \
-               pa=$(DESTDIR)$(sbindir)/`echo $$p|sed '$(transform)'`; \
-               echo chown $(BINARY_OWNER) $$pa; \
-               chown $(BINARY_OWNER) $$pa; \
-               echo chgrp $(SETUID_GROUP) $$pa; \
-               chgrp $(SETUID_GROUP) $$pa; \
-               echo chmod o-rwx $$pa; \
-               chmod o-rwx $$pa; \
-       done
-
 # so that uscan.c is never generated before uparse.h
 # otherwise we might have makedepend problems
 uscan.c: uparse.h
+
+# these two commands are specially defined to omit $(AMANDA_WARNING_CFLAGS)
+# since we don't want warnings for generated code
+uscan.$(OBJEXT): uscan.c
+       $(CC) $(CFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(CPPFLAGS) -c $<
+
+uparse.$(OBJEXT): uparse.c
+       $(CC) $(CFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(CPPFLAGS) -c $<
+
+INSTALLPERMS_exec = \
+       dest=$(sbindir) chown=amanda chmod=0750 $(sbin_PROGRAMS)
+
+lint:
+       @f="$(amrecover_CSRC)";                                                 \
+       (cd ../common-src; make listlibsrc);                                    \
+       f="$$f "`cat ../common-src/listlibsrc.output`;                          \
+       (cd ../server-src; make listlibsrc);                                    \
+       f="$$f "`cat ../server-src/listlibsrc.output`;                          \
+       echo $(LINT) $$f;                                                       \
+       $(LINT) $(LINTFLAGS) $(CPPFLAGS) $(DEFS) -I. -I$(top_builddir)/config $(INCLUDES) $$f;\
+       if [ $$? -ne 0 ]; then                                                  \
+           exit 1;                                                             \
+       fi;                                                                     \
+        exit 0
+