patches from Simon Ruderich that broaden use of hardening build flags
[debian/sudo] / plugins / sudoers / Makefile.in
index 6c3c35c79451a6b2989f49c74ade0ba8bb0f4ede..71a316d97e53f01d97aa1bb4abea84e7aa14ee37 100644 (file)
@@ -159,7 +159,7 @@ Makefile: $(srcdir)/Makefile.in
        (cd $(top_builddir) && ./config.status --file plugins/sudoers/Makefile)
 
 libparsesudoers.la: $(LIBPARSESUDOERS_OBJS)
-       $(LIBTOOL) --mode=link $(CC) -o $@ $(LIBPARSESUDOERS_OBJS) -no-install
+       $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(LIBPARSESUDOERS_OBJS) -no-install
 
 sudoers.la: $(SUDOERS_OBJS) $(LT_LIBS) libparsesudoers.la
        $(LIBTOOL) @LT_STATIC@ --mode=link $(CC) $(SUDOERS_LDFLAGS) $(LTLDFLAGS) -o $@ $(SUDOERS_OBJS) libparsesudoers.la $(SUDOERS_LIBS) -module -export-symbols $(srcdir)/sudoers.sym -avoid-version -rpath $(plugindir)