Imported Upstream version 1.8.2
[debian/sudo] / plugins / sample_group / Makefile.in
index eda9f1f452c0205ec6f211d29c6da71f648636f6..9c4207ad72f570eb8a602558072530f93757ebb9 100644 (file)
@@ -80,12 +80,6 @@ Makefile: $(srcdir)/Makefile.in
 .c.lo:
        $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
 
-getgrent.lo: $(srcdir)/getgrent.c
-       $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/getgrent.c
-
-sample_group.lo: $(srcdir)/sample_group.c
-       $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/sample_group.c
-
 sample_group.la: $(OBJS)
        $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LTLDFLAGS) -o $@ $(OBJS) $(LIBS) -module -export-symbols $(srcdir)/sample_group.sym -avoid-version -rpath $(plugindir)
 
@@ -124,3 +118,10 @@ realclean: distclean
        rm -f TAGS tags
 
 cleandir: realclean
+
+# Autogenerated dependencies, do not modify
+getgrent.lo: $(srcdir)/getgrent.c $(top_builddir)/config.h $(incdir)/missing.h
+       $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/getgrent.c
+sample_group.lo: $(srcdir)/sample_group.c $(top_builddir)/config.h \
+                 $(incdir)/sudo_plugin.h $(incdir)/missing.h
+       $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $(srcdir)/sample_group.c