Imported Upstream version 1.8.5
[debian/sudo] / plugins / sample_group / Makefile.in
index b9812b50d8304ce34dcaf9cd9606b4edf7c2f631..46b2001fc32b1496fa9e867340c46b3b44ea5579 100644 (file)
@@ -33,7 +33,8 @@ LIBTOOL = @LIBTOOL@ @LT_STATIC@
 INSTALL = $(SHELL) $(top_srcdir)/install-sh -c
 
 # Libraries
-LIBS = $(LIBOBJDIR)/libreplace.la
+LT_LIBS = $(LIBOBJDIR)libreplace.la
+LIBS = $(LT_LIBS)
 
 # C preprocessor flags
 CPPFLAGS = -I$(incdir) -I$(top_builddir) -I$(top_srcdir) @CPPFLAGS@
@@ -80,7 +81,7 @@ Makefile: $(srcdir)/Makefile.in
 .c.lo:
        $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) $(DEFS) $<
 
-sample_group.la: $(OBJS)
+sample_group.la: $(OBJS) $(LT_LIBS)
        $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LTLDFLAGS) -o $@ $(OBJS) $(LIBS) -module -export-symbols $(srcdir)/sample_group.sym -avoid-version -rpath $(plugindir)
 
 pre-install: