Imported Upstream version 3.3.2
[debian/amanda] / perl / Makefile.am
index f58c9703d851f9387a674c1e5fa56dd48549d0a5..cdf7eb12c94eceab9e4a2711427dcf4c60fc7daa 100644 (file)
@@ -53,7 +53,7 @@ endif
 html: make_html amperl.css $(PM_FILES)
        rm -rf html-tmp/ && mkdir html-tmp/
        cp amperl.css html-tmp/
-       $(PERL) make_html html-tmp/ $(PM_FILES)
+       $(PERL) make_html --homeurl "$(POD_HOME_URL)" html-tmp/ $(PM_FILES)
        cd html-tmp/ && tar -zcf $(abs_builddir)/html.tar.gz .
        rm -rf html-tmp/
 ##
@@ -526,7 +526,7 @@ EXTRA_DIST += Amanda/Application/Zfs.pm
 if WANT_CYGWIN_COPY_PERL_DLL
 amperldirauto="$(DESTDIR)$(amperldir)/auto/Amanda"
 install-data-hook:
-       @for cygdll in $(amperldirauto)/bin/cyg*.dll; do \
+       @for cygdll in $(wildcard $(amperldirauto)/bin/cyg*.dll); do \
            destfname=`echo $$cygdll|sed 's!/bin/cyg\([^.]*\).dll!/\1/\1.dll!'`; \
           cp "$$cygdll" "$$destfname"; \
        done