work on xcvr set_freq
[debian/gnuradio] / omnithread / Makefile.am
index edf9c3c24699ad6a1a4c6f249e9a70cdfcc5b5e4..d0dde72b2a27d3691c6f0765d06b5d4a38947569 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2003 Free Software Foundation, Inc.
+# Copyright 2003,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -27,7 +27,8 @@ include $(top_srcdir)/Makefile.common
 # we should do some configure hacking to determine these on the fly
 OMNITHREAD_DEFINES = -DPthreadDraftVersion=10
 
-INCLUDES = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES)
+AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES) \
+        $(WITH_INCLUDES)
 
 # we call it libgromnithread to avoid a collision with libomnithread on Debian
 lib_LTLIBRARIES = libgromnithread.la
@@ -36,22 +37,28 @@ lib_LTLIBRARIES = libgromnithread.la
 
 if OMNITHREAD_POSIX
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        posix.cc
 endif
 
 if OMNITHREAD_NT
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        nt.cc
 endif
 
-libgromnithread_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version 
+libgromnithread_la_LDFLAGS = $(NO_UNDEFINED) 
 
 libgromnithread_la_LIBADD =            \
        $(PTHREAD_LIBS)
 
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gnuradio-omnithread.pc
+
 # ... but this code also came with the package
 
 EXTRA_DIST =                           \
+       gnuradio-omnithread.pc.in       \
        mach.cc                         \
        nt.cc                           \
        posix.cc                        \
@@ -62,6 +69,7 @@ EXTRA_DIST =                          \
 
 grinclude_HEADERS =                    \
        omnithread.h                    \
+       omni_time.h                     \
        ot_mach.h                       \
        ot_nt.h                         \
        ot_posix.h                      \