Merge commit 'v3.3.0' into upstream
[debian/gnuradio] / omnithread / Makefile.am
index 0985f4ed454b0abea4e24f8d074f0e8f251d0de5..88df2714da9b4f0a5b3af36500391ab8505a2688 100644 (file)
@@ -21,6 +21,8 @@
 
 include $(top_srcdir)/Makefile.common
 
+SUBDIRS = gnuradio
+
 # This is the omnithread package,
 #   extracted from the omniORB-4.0.1 distribution
 
@@ -37,11 +39,13 @@ lib_LTLIBRARIES = libgromnithread.la
 
 if OMNITHREAD_POSIX
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        posix.cc
 endif
 
 if OMNITHREAD_NT
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        nt.cc
 endif
 
@@ -64,12 +68,3 @@ EXTRA_DIST =                         \
        threaddata.cc                   \
        vxWorks.cc                      \
        dir.mk
-
-grinclude_HEADERS =                    \
-       omnithread.h                    \
-       ot_mach.h                       \
-       ot_nt.h                         \
-       ot_posix.h                      \
-       ot_pthread_nt.h                 \
-       ot_solaris.h                    \
-       ot_VxThread.h