make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / omnithread / Makefile.am
index 59ba971a445220d1930116def0122c55247edf04..88df2714da9b4f0a5b3af36500391ab8505a2688 100644 (file)
 
 include $(top_srcdir)/Makefile.common
 
+SUBDIRS = gnuradio
+
 # This is the omnithread package,
 #   extracted from the omniORB-4.0.1 distribution
 
 # we should do some configure hacking to determine these on the fly
 OMNITHREAD_DEFINES = -DPthreadDraftVersion=10
 
-INCLUDES = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES) \
+AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_DEFINES) $(OMNITHREAD_INCLUDES) \
         $(WITH_INCLUDES)
 
 # we call it libgromnithread to avoid a collision with libomnithread on Debian
@@ -37,11 +39,13 @@ lib_LTLIBRARIES = libgromnithread.la
 
 if OMNITHREAD_POSIX
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        posix.cc
 endif
 
 if OMNITHREAD_NT
 libgromnithread_la_SOURCES =           \
+       omni_time.cc \
        nt.cc
 endif
 
@@ -64,12 +68,3 @@ EXTRA_DIST =                         \
        threaddata.cc                   \
        vxWorks.cc                      \
        dir.mk
-
-grinclude_HEADERS =                    \
-       omnithread.h                    \
-       ot_mach.h                       \
-       ot_nt.h                         \
-       ot_posix.h                      \
-       ot_pthread_nt.h                 \
-       ot_solaris.h                    \
-       ot_VxThread.h