Tweaks to Debian packaging.
[debian/gnuradio] / mblock / src / lib / Makefile.am
index 604f97246a4de2b6f8beefdfcce5fa03ba09c99d..9a653759de79cf8bcae9106e643f2f5a6d08fa10 100644 (file)
@@ -5,7 +5,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -36,7 +36,7 @@ BUILT_SOURCES =                               \
        qa_bitset_mbh.cc                
 
 qa_bitset_mbh.cc : qa_bitset.mbh
-       $(COMPILE_MBH) qa_bitset.mbh qa_bitset_mbh.cc
+       $(COMPILE_MBH) $(srcdir)/qa_bitset.mbh qa_bitset_mbh.cc
 
 # These are the source files that go into the mblock shared library
 libmblock_la_SOURCES =                 \
@@ -66,7 +66,7 @@ libmblock_la_SOURCES =                        \
 
 
 # magic flags
-libmblock_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libmblock_la_LDFLAGS = $(NO_UNDEFINED)
 
 # link the library against the c++ standard library
 libmblock_la_LIBADD =                  \