Doc fixes. Merged eb/t367 -r11020:11025 to trunk. This changeset
[debian/gnuradio] / mblock / src / lib / Makefile.am
index 604f97246a4de2b6f8beefdfcce5fa03ba09c99d..81079f032a480e3db5178638aa055a04b861bc9c 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2006,2007 Free Software Foundation, Inc.
+# Copyright 2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 include $(top_srcdir)/Makefile.common
 
-INCLUDES = $(DEFINES) $(OMNITHREAD_INCLUDES) $(PMT_INCLUDES) $(BOOST_CFLAGS) $(CPPUNIT_INCLUDES)
+AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_INCLUDES) $(PMT_INCLUDES) \
+       $(BOOST_CPPFLAGS) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES) \
+       $(MBLOCK_INCLUDES)
 
-TESTS = test_mblock
+# disable test until we fix ticket:180
+# TESTS = test_mblock
 
 lib_LTLIBRARIES = libmblock.la libmblock-qa.la
 
@@ -36,7 +39,7 @@ BUILT_SOURCES =                               \
        qa_bitset_mbh.cc                
 
 qa_bitset_mbh.cc : qa_bitset.mbh
-       $(COMPILE_MBH) qa_bitset.mbh qa_bitset_mbh.cc
+       $(COMPILE_MBH) $(srcdir)/qa_bitset.mbh qa_bitset_mbh.cc
 
 # These are the source files that go into the mblock shared library
 libmblock_la_SOURCES =                 \
@@ -59,14 +62,13 @@ libmblock_la_SOURCES =                      \
        mb_runtime_base.cc              \
        mb_runtime_nop.cc               \
        mb_runtime_thread_per_block.cc  \
-       mb_time.cc                      \
        mb_timer_queue.cc               \
        mb_util.cc                      \
        mb_worker.cc                    
 
 
 # magic flags
-libmblock_la_LDFLAGS = $(NO_UNDEFINED) -avoid-version
+libmblock_la_LDFLAGS = $(NO_UNDEFINED)
 
 # link the library against the c++ standard library
 libmblock_la_LIBADD =                  \
@@ -74,25 +76,11 @@ libmblock_la_LIBADD =                       \
        $(PMT_LA)                       \
        -lstdc++                        
 
-include_HEADERS =                      \
-       mb_class_registry.h             \
-       mb_common.h                     \
-       mb_exception.h                  \
+noinst_HEADERS =                       \
        mb_gettid.h                     \
-       mb_mblock.h                     \
-       mb_message.h                    \
-       mb_msg_accepter.h               \
        mb_msg_accepter_msgq.h          \
-       mb_msg_queue.h                  \
-       mb_port.h                       \
        mb_port_simple.h                \
-       mb_protocol_class.h             \
-       mb_runtime.h                    \
-       mb_time.h                       \
-       mb_util.h                       
-
-
-noinst_HEADERS =                       \
+       mb_util.h                       \
        mb_connection.h                 \
        mb_endpoint.h                   \
        mb_mblock_impl.h                \
@@ -142,5 +130,3 @@ test_mblock_LDADD   = libmblock-qa.la
 
 benchmark_send_SOURCES = benchmark_send.cc
 benchmark_send_LDADD   = libmblock-qa.la
-
-CLEANFILES = $(BUILT_SOURCES) *.pyc