Merge commit 'v3.3.1' into try-3.3.1
[debian/gnuradio] / mblock / src / lib / Makefile.am
index a005f83008aac3936adaa92e6da1b32eaa159546..81079f032a480e3db5178638aa055a04b861bc9c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2006,2007,2008 Free Software Foundation, Inc.
+# Copyright 2006,2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -22,7 +22,8 @@
 include $(top_srcdir)/Makefile.common
 
 AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_INCLUDES) $(PMT_INCLUDES) \
-       $(BOOST_CFLAGS) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
+       $(BOOST_CPPFLAGS) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES) \
+       $(MBLOCK_INCLUDES)
 
 # disable test until we fix ticket:180
 # TESTS = test_mblock
@@ -75,25 +76,11 @@ libmblock_la_LIBADD =                       \
        $(PMT_LA)                       \
        -lstdc++                        
 
-include_HEADERS =                      \
-       mb_class_registry.h             \
-       mb_common.h                     \
-       mb_exception.h                  \
+noinst_HEADERS =                       \
        mb_gettid.h                     \
-       mb_mblock.h                     \
-       mb_message.h                    \
-       mb_msg_accepter.h               \
        mb_msg_accepter_msgq.h          \
-       mb_msg_queue.h                  \
-       mb_port.h                       \
        mb_port_simple.h                \
-       mb_protocol_class.h             \
-       mb_runtime.h                    \
-       mb_time.h                       \
-       mb_util.h                       
-
-
-noinst_HEADERS =                       \
+       mb_util.h                       \
        mb_connection.h                 \
        mb_endpoint.h                   \
        mb_mblock_impl.h                \
@@ -143,5 +130,3 @@ test_mblock_LDADD   = libmblock-qa.la
 
 benchmark_send_SOURCES = benchmark_send.cc
 benchmark_send_LDADD   = libmblock-qa.la
-
-CLEANFILES = $(BUILT_SOURCES) *.pyc