Imported Upstream version 3.3.1
[debian/amanda] / man / Makefile.am
index 2525dee74a8f6e56f445081fab0250746fb2be4d..79106bd897796244dd935f24ae3daec4bf4dbb71 100644 (file)
@@ -1,5 +1,7 @@
 # Makefile for amanda man-pages
 
+.SECONDARY:
+
 transform =    s,x,x,;
 
 AMPLOT_MAN_PAGES =  amplot.8
@@ -10,20 +12,29 @@ COMMON_MAN_PAGES =  amanda.8 \
                    amanda-scripts.7 \
                    amanda-archive-format.5 \
                    amanda-auth.7 \
+                   amanda-match.7 \
                    amarchiver.8 \
+                   amservice.8 \
                    script-email.8
 
 CLIENT_MAN_PAGES = \
     amanda-applications.7 \
+    amdump_client.8 \
     amgtar.8 \
+    ampgsql.8 \
+    amraw.8 \
     amsamba.8 \
     amstar.8 \
+    amsuntar.8 \
     amzfs-snapshot.8 \
     amzfs-sendrecv.8
 
 SERVER_MAN_PAGES =  \
     amanda-devices.7 \
+    amanda-compatibility.7 \
     amanda-changers.7 \
+    amanda-interactivity.7 \
+    amanda-taperscan.7 \
     amaddclient.8    \
     amadmin.8 \
     amaespipe.8 \
@@ -31,6 +42,7 @@ SERVER_MAN_PAGES =  \
     amcheckdb.8 \
     amcheckdump.8 \
     amcleanup.8 \
+    amcleanupdisk.8 \
     amcrypt-ossl-asym.8 \
     amcrypt-ossl.8   \
     amcrypt.8 \
@@ -45,7 +57,6 @@ SERVER_MAN_PAGES =  \
     amreport.8 \
     amrmtape.8 \
     amserverconfig.8 \
-    amservice.8 \
     amstatus.8 \
     amtape.8 \
     amtapetype.8 \
@@ -113,14 +124,14 @@ entities/global.entities: entities/global.entities.in $(top_builddir)/config.sta
 if   ENABLE_MANPAGE_BUILD
 # phase one of the documentation build expands some macros.
 xml-source/%.proc.xml: $(SRCMANPAGEDIR)/%.xml $(srcdir)/xslt/expand-sambadoc.xsl entities/global.entities
-       $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --xinclude --stringparam latex.imagebasedir "$*/" --stringparam noreference 1 --output $@ $(srcdir)/xslt/expand-sambadoc.xsl $<
+       $(XSLTPROC) $(XSLTPROC_FLAGS) --path "$(srcdir)/xslt/:$(builddir)/entities/" --xinclude --stringparam latex.imagebasedir "$*/" --stringparam noreference 1 --output $@ $(srcdir)/xslt/expand-sambadoc.xsl $<
 
 # phase two generates a manpage from the resulting "expanded" docbook XML
 %: xml-source/%.proc.xml $(srcdir)/xslt/man.xsl entities/global.entities
-       $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --output $@ xslt/man.xsl $<
+       $(XSLTPROC) $(XSLTPROC_FLAGS) --path "$(srcdir)/xslt/:$(builddir)/entities/" --output $@ xslt/man.xsl $<
 
 %.html: xml-source/%.proc.xml $(srcdir)/xslt/html.xsl entities/global.entities
-       $(XSLTPROC) $(XSLTPROC_FLAGS) --path $(srcdir)/xslt/ --output $@ xslt/html.xsl $<
+       $(XSLTPROC) $(XSLTPROC_FLAGS) --path "$(srcdir)/xslt/:$(builddir)/entities/" --output $@ xslt/html.xsl $<
 
 else   !ENABLE_MANPAGE_BUILD