update patch to include tweak to lib/gnulib.mk
[debian/gzip] / m4 / sys_time_h.m4
index b38e1bc5f1a38dd14fa56367f3e90708226ebaf6..9c16487957bc27ffd4ade8eba9943b1fb138df5d 100644 (file)
@@ -1,6 +1,7 @@
 # Configure a replacement for <sys/time.h>.
+# serial 2
 
-# Copyright (C) 2007 Free Software Foundation, Inc.
+# Copyright (C) 2007, 2009, 2010 Free Software Foundation, Inc.
 # This file is free software; the Free Software Foundation
 # gives unlimited permission to copy and/or distribute it,
 # with or without modifications, as long as this notice is preserved.
@@ -19,27 +20,24 @@ AC_DEFUN([gl_HEADER_SYS_TIME_H_BODY],
 [
   AC_REQUIRE([AC_C_RESTRICT])
   AC_CHECK_HEADERS_ONCE([sys/time.h])
+  gl_CHECK_NEXT_HEADERS([sys/time.h])
 
   if test $ac_cv_header_sys_time_h = yes; then
-    gl_ABSOLUTE_HEADER([sys/time.h])
-    ABSOLUTE_SYS_TIME_H=\"$gl_cv_absolute_sys_time_h\"
     HAVE_SYS_TIME_H=1
   else
-    ABSOLUTE_SYS_TIME_H=\"no/such/file/sys/time.h\"
     HAVE_SYS_TIME_H=0
   fi
-  AC_SUBST([ABSOLUTE_SYS_TIME_H])
   AC_SUBST([HAVE_SYS_TIME_H])
 
   AC_CACHE_CHECK([for struct timeval], [gl_cv_sys_struct_timeval],
     [AC_COMPILE_IFELSE(
        [AC_LANG_PROGRAM(
-         [[#if HAVE_SYS_TIME_H
-            #include <sys/time.h>
-           #endif
-           #include <time.h>
-         ]],
-         [[static struct timeval x; x.tv_sec = x.tv_usec;]])],
+          [[#if HAVE_SYS_TIME_H
+             #include <sys/time.h>
+            #endif
+            #include <time.h>
+          ]],
+          [[static struct timeval x; x.tv_sec = x.tv_usec;]])],
        [gl_cv_sys_struct_timeval=yes],
        [gl_cv_sys_struct_timeval=no])])
   if test $gl_cv_sys_struct_timeval = yes; then