make lintian happier by updating standards version
[debian/gzip] / lib / Makefile.am
index 3c57520be4b6080bba9a4dfbd39ede169bc7aa05..7812a3eb52d8008e822a91321a3506622541acb6 100644 (file)
@@ -1,10 +1,10 @@
 # Make gzip/lib                                -*-Makefile-*-
 
-# Copyright (C) 2006 Free Software Foundation, Inc.
+# Copyright (C) 2006, 2009-2013 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
+# the Free Software Foundation; either version 3 of the License, or
 # (at your option) any later version.
 
 # This program is distributed in the hope that it will be useful,
 # with this program; if not, write to the Free Software Foundation, Inc.,
 # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
+AM_CFLAGS =
+BUILT_SOURCES =
+CLEANFILES =
+EXTRA_DIST =
+MOSTLYCLEANDIRS =
+MOSTLYCLEANFILES =
+SUFFIXES =
+noinst_LIBRARIES =
 
 include gnulib.mk
 
 libgzip_a_LIBADD += $(LIBOBJS)
 libgzip_a_DEPENDENCIES += $(LIBOBJS)
+AM_CFLAGS += $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)
 
 match.$(OBJEXT): match.c
-       cp $(srcdir)/match.c _match.S
-       $(CPP) $(CPPFLAGS) $(ASCPPFLAGS) _match.S > _match.i
-       @ASCPPPOST@ < _match.i > match_.s
-       $(CC) $(CPPFLAGS) $(CFLAGS) $(ASFLAGS_config) -c match_.s
-       mv match_.$(OBJEXT) $@
-       rm -f _match.S _match.i match_.s
+       $(AM_V_GEN)cp $(srcdir)/match.c _match.S
+       $(AM_V_at)$(CPP) $(CPPFLAGS) $(ASCPPFLAGS) _match.S > _match.i
+       $(AM_V_at)$(ASCPPPOST) < _match.i > match_.s
+       $(AM_V_at)$(CC) $(CPPFLAGS) $(CFLAGS) $(ASFLAGS_config) -c match_.s
+       $(AM_V_at)mv match_.$(OBJEXT) $@
+       $(AM_V_at)rm -f _match.S _match.i match_.s
 
 MOSTLYCLEANFILES += _match.S _match.i match_.s