maint: use noreturn, not ATTRIBUTE_NORETURN
[debian/gzip] / lib / .gitignore
index aa1285312e93960954f4f6341a218ab05ffcac6c..6b1ea36ba62f469d604faf71fbb57bd0151e4c11 100644 (file)
@@ -1,34 +1,22 @@
 .deps
 /Makefile
 /Makefile.in
+/_Noreturn.h
 /alloca.h
 /alloca.in.h
 /asnprintf.c
+/assure.h
+/at-func.c
 /basename-lgpl.c
-/c-ctype.c
-/c-ctype.h
-/c-strcase.h
-/c-strcasecmp.c
-/c-strcaseeq.h
-/c-strncasecmp.c
 /calloc.c
-/charset.alias
 /chdir-long.c
 /chdir-long.h
 /cloexec.c
 /cloexec.h
-/close-stream.c
-/close-stream.h
 /close.c
 /closedir.c
-/closein.c
-/closein.h
-/closeout.c
-/closeout.h
-/config.charset
 /config.h
 /config.hin
-/configmake.h
 /creat-safer.c
 /dirent--.h
 /dirent-private.h
@@ -39,6 +27,7 @@
 /dirname-lgpl.c
 /dirname.h
 /dosname.h
+/dup-safer-flag.c
 /dup-safer.c
 /dup.c
 /dup2.c
@@ -57,7 +46,9 @@
 /fcntl.in.h
 /fd-hook.c
 /fd-hook.h
+/fd-safer-flag.c
 /fd-safer.c
+/fdatasync.c
 /fdopendir.c
 /fflush.c
 /filename.h
 /float.c
 /float.h
 /float.in.h
-/fpending.c
-/fpending.h
 /fprintf.c
 /fpucw.h
 /fpurge.c
-/freadahead.c
-/freadahead.h
 /freading.c
 /freading.h
 /frexp.c
 /fseterr.c
 /fseterr.h
 /fstat.c
+/fstatat.c
+/fsync.c
 /ftell.c
 /ftello.c
 /getcwd-lgpl.c
 /getdtablesize.c
+/getopt-cdefs.in.h
+/getopt-core.h
+/getopt-ext.h
+/getopt-pfx-core.h
+/getopt-pfx-ext.h
 /getopt.c
 /getopt.h
 /getopt.in.h
 /getopt1.c
 /getopt_int.h
+/getprogname.c
+/getprogname.h
 /gettext.h
 /gettime.c
 /gettimeofday.c
 /isnanl.c
 /itold.c
 /libgzip.a
-/localcharset.c
-/localcharset.h
+/limits.h
+/limits.in.h
+/localtime-buffer.c
+/localtime-buffer.h
 /lseek.c
 /lstat.c
 /malloc.c
+/malloca.c
+/malloca.h
+/malloca.valgrind
 /math.c
 /math.h
 /math.in.h
-/mbrtowc.c
-/mbsinit.c
 /memchr.c
 /memchr.valgrind
 /mempcpy.c
 /openat-die.c
 /openat-priv.h
 /openat-proc.c
+/openat-safer.c
 /openat.c
 /openat.h
 /opendir-safer.c
 /printf-parse.c
 /printf-parse.h
 /printf.c
-/quote.h
-/quotearg.c
-/quotearg.h
 /readdir.c
 /realloc.c
-/ref-add.sed
-/ref-add.sin
-/ref-del.sed
-/ref-del.sin
+/rmdir.c
 /save-cwd.c
 /save-cwd.h
 /savedir.c
 /stamp-h1
 /stat-time.c
 /stat-time.h
+/stat-w32.c
+/stat-w32.h
 /stat.c
+/statat.c
 /stdbool.h
 /stdbool.in.h
 /stddef.h
 /stdlib.in.h
 /stpcpy.c
 /strdup.c
-/streq.h
 /strerror-override.c
 /strerror-override.h
 /strerror.c
 /string.in.h
 /stripslash.c
 /sys
-/sys_stat.h
 /sys_stat.in.h
-/sys_time.h
 /sys_time.in.h
 /sys_types.in.h
 /time.h
 /unistd.c
 /unistd.h
 /unistd.in.h
+/unlink.c
+/unlinkat.c
 /unused-parameter.h
+/utime.c
+/utime.in.h
 /utimens.c
 /utimens.h
 /vasnprintf.c
 /vfprintf.c
 /wchar.h
 /wchar.in.h
-/wctype-h.c
-/wctype.h
-/wctype.in.h
 /xalloc-die.c
 /xalloc-oversized.h
 /xalloc.h
 /xsize.h
 /yesno.c
 /yesno.h
+/stdnoreturn.in.h