maint: use noreturn, not ATTRIBUTE_NORETURN
[debian/gzip] / lib / .gitignore
index 0d8e8e57c2f3110f47a8ff0f760e357f2a5952d8..6b1ea36ba62f469d604faf71fbb57bd0151e4c11 100644 (file)
@@ -1,40 +1,33 @@
 .deps
 /Makefile
 /Makefile.in
+/_Noreturn.h
 /alloca.h
 /alloca.in.h
 /asnprintf.c
+/assure.h
 /at-func.c
 /basename-lgpl.c
 /calloc.c
-/charset.alias
 /chdir-long.c
 /chdir-long.h
-/chown.c
 /cloexec.c
 /cloexec.h
-/close-hook.c
-/close-hook.h
-/close-stream.c
-/close-stream.h
 /close.c
 /closedir.c
-/closein.c
-/closein.h
-/closeout.c
-/closeout.h
-/config.charset
 /config.h
 /config.hin
-/configmake.h
 /creat-safer.c
+/dirent--.h
 /dirent-private.h
+/dirent-safer.h
 /dirent.h
 /dirent.in.h
 /dirfd.c
 /dirname-lgpl.c
 /dirname.h
 /dosname.h
+/dup-safer-flag.c
 /dup-safer.c
 /dup.c
 /dup2.c
 /exitfail.c
 /exitfail.h
 /fchdir.c
-/fchmodat.c
-/fchown-stub.c
-/fchownat.c
 /fclose.c
 /fcntl--.h
 /fcntl-safer.h
 /fcntl.c
 /fcntl.h
 /fcntl.in.h
-/fcntl_.h
 /fd-hook.c
 /fd-hook.h
+/fd-safer-flag.c
 /fd-safer.c
+/fdatasync.c
 /fdopendir.c
 /fflush.c
 /filename.h
 /float.c
 /float.h
 /float.in.h
-/fpending.c
-/fpending.h
 /fprintf.c
 /fpucw.h
 /fpurge.c
-/fpurge.h
-/freadahead.c
-/freadahead.h
 /freading.c
 /freading.h
 /frexp.c
 /fseterr.h
 /fstat.c
 /fstatat.c
+/fsync.c
 /ftell.c
 /ftello.c
 /getcwd-lgpl.c
-/getcwd.c
 /getdtablesize.c
+/getopt-cdefs.in.h
+/getopt-core.h
+/getopt-ext.h
+/getopt-pfx-core.h
+/getopt-pfx-ext.h
 /getopt.c
 /getopt.h
 /getopt.in.h
 /getopt1.c
 /getopt_int.h
-/getpagesize.c
+/getprogname.c
+/getprogname.h
 /gettext.h
 /gettime.c
 /gettimeofday.c
+/glthread
 /gnulib.mk
 /ignore-value.h
 /intprops.h
 /isnanf.c
 /isnanl-nolibm.h
 /isnanl.c
-/iswblank.c
 /itold.c
-/lchown.c
 /libgzip.a
-/localcharset.c
-/localcharset.h
+/limits.h
+/limits.in.h
+/localtime-buffer.c
+/localtime-buffer.h
 /lseek.c
 /lstat.c
 /malloc.c
+/malloca.c
+/malloca.h
+/malloca.valgrind
+/math.c
 /math.h
 /math.in.h
-/mbrtowc.c
-/mbsinit.c
 /memchr.c
 /memchr.valgrind
 /mempcpy.c
 /memrchr.c
-/mkdir.c
-/mkdirat.c
 /msvc-inval.c
 /msvc-inval.h
 /msvc-nothrow.c
 /openat-die.c
 /openat-priv.h
 /openat-proc.c
+/openat-safer.c
 /openat.c
 /openat.h
+/opendir-safer.c
 /opendir.c
 /pathmax.h
 /perror.c
 /printf-parse.c
 /printf-parse.h
 /printf.c
-/quotearg.c
-/quotearg.h
+/readdir.c
 /realloc.c
-/ref-add.sed
-/ref-add.sin
-/ref-del.sed
-/ref-del.sin
 /rmdir.c
-/same-inode.h
 /save-cwd.c
 /save-cwd.h
+/savedir.c
+/savedir.h
 /signbitd.c
 /signbitf.c
 /signbitl.c
 /size_max.h
 /stamp-h1
+/stat-time.c
 /stat-time.h
+/stat-w32.c
+/stat-w32.h
 /stat.c
+/statat.c
 /stdbool.h
 /stdbool.in.h
-/stdbool_.h
 /stddef.h
 /stddef.in.h
 /stdint.h
 /stdint.in.h
 /stdio-impl.h
-/stdio-write.c
 /stdio.h
 /stdio.in.h
-/stdio_.h
 /stdlib.h
 /stdlib.in.h
-/stdlib_.h
+/stpcpy.c
 /strdup.c
-/streq.h
 /strerror-override.c
 /strerror-override.h
 /strerror.c
 /string.in.h
 /stripslash.c
 /sys
-/sys_stat.h
 /sys_stat.in.h
-/sys_stat_.h
-/sys_time.h
 /sys_time.in.h
-/sys_time_.h
+/sys_types.in.h
 /time.h
 /time.in.h
-/time_.h
+/timespec.c
 /timespec.h
 /unistd--.h
 /unistd-safer.h
+/unistd.c
 /unistd.h
 /unistd.in.h
-/unistd_.h
 /unlink.c
 /unlinkat.c
+/unused-parameter.h
+/utime.c
+/utime.in.h
 /utimens.c
 /utimens.h
 /vasnprintf.c
 /vfprintf.c
 /wchar.h
 /wchar.in.h
-/wchar_.h
-/wctype.h
-/wctype.in.h
-/wctype_.h
 /xalloc-die.c
 /xalloc-oversized.h
 /xalloc.h
-/xgetcwd.c
-/xgetcwd.h
 /xmalloc.c
+/xsize.c
 /xsize.h
 /yesno.c
 /yesno.h
-/dirent--.h
-/dirent-safer.h
-/opendir-safer.c
-/readdir.c
-/savedir.c
-/savedir.h
+/stdnoreturn.in.h