Imported Upstream version 3.2.2
[debian/gnuradio] / grc / grc_gnuradio / Makefile.am
diff --git a/grc/grc_gnuradio/Makefile.am b/grc/grc_gnuradio/Makefile.am
new file mode 100644 (file)
index 0000000..63bb728
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+include $(top_srcdir)/Makefile.common
+
+grc_gnuradio_prefix = $(pythondir)/grc_gnuradio
+
+root_pythondir = $(grc_gnuradio_prefix)
+root_python_PYTHON = __init__.py
+
+blks2_pythondir = $(grc_gnuradio_prefix)/blks2
+blks2_python_PYTHON = \
+       blks2/__init__.py \
+       blks2/error_rate.py \
+       blks2/packet.py \
+       blks2/probe.py \
+       blks2/selector.py \
+       blks2/tcp.py \
+       blks2/variable_sink.py
+
+usrp_pythondir = $(grc_gnuradio_prefix)/usrp
+usrp_python_PYTHON = \
+       usrp/__init__.py \
+       usrp/common.py \
+       usrp/dual_usrp.py \
+       usrp/simple_usrp.py
+
+wxgui_pythondir = $(grc_gnuradio_prefix)/wxgui
+wxgui_python_PYTHON = \
+       wxgui/__init__.py \
+       wxgui/panel.py \
+       wxgui/top_block_gui.py