make maintainer-clean removes these, and we want a clean orig.tar.gz
[debian/gnuradio] / grc / Makefile.am
index 8b77fc31a5bba87b4b3c38283a5c854be4f347b1..2b5dc730b5e3184b9c25c6ad3e1a34f4b0dd0cde 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008, 2009 Free Software Foundation, Inc.
 #
 # This file is part of GNU Radio
 #
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
-SUBDIRS = $(XDG_UTILS) \
-       data \
-       examples \
-       scripts \
-       src
+if PYTHON
+SUBDIRS = \
+       base \
+       blocks \
+       grc_gnuradio \
+       gui \
+       python \
+       scripts
+
+## append freedesktop to the list of subdirs when xdg utils are present
+if XDG_UTILS
+SUBDIRS += freedesktop
+endif
+
+ourpythondir = $(pkgpythondir)/grc
+ourpython_PYTHON = __init__.py
+
+etcdir = $(gr_prefsdir)
+dist_etc_DATA = grc.conf
+
+EXTRA_DIST = $(srcdir)/grc.conf.in
+
+BUILT_SOURCES = grc.conf
+
+grc.conf: $(srcdir)/grc.conf.in Makefile
+       sed \
+               -e 's|@pythonw[@]|$(PYTHONW)|g' \
+               -e 's|@blocksdir[@]|$(grc_blocksdir)|g' \
+               -e 's|@docdir[@]|$(gr_docdir)|g' \
+       $< > $@
+
+endif