Adding typedef for uint64_t and int64_t so we can use them through SWIG.
[debian/gnuradio] / grc / Makefile.am
index 4ffdee0b42150eb6d0ac5456a65ef186b2a0a8b5..2b5dc730b5e3184b9c25c6ad3e1a34f4b0dd0cde 100644 (file)
 # Boston, MA 02110-1301, USA.
 #
 
-include $(top_srcdir)/grc/Makefile.inc
+include $(top_srcdir)/Makefile.common
 
 if PYTHON
 SUBDIRS = \
        base \
        blocks \
-       examples \
        grc_gnuradio \
        gui \
        python \
@@ -36,24 +35,15 @@ if XDG_UTILS
 SUBDIRS += freedesktop
 endif
 
-ourpythondir = $(grc_src_prefix)
+ourpythondir = $(pkgpythondir)/grc
 ourpython_PYTHON = __init__.py
 
 etcdir = $(gr_prefsdir)
 dist_etc_DATA = grc.conf
 
-EXTRA_DIST = \
-       $(srcdir)/__init__.py.in \
-       $(srcdir)/grc.conf.in
+EXTRA_DIST = $(srcdir)/grc.conf.in
 
-BUILT_SOURCES = \
-       __init__.py \
-       grc.conf
-
-__init__.py: $(srcdir)/__init__.py.in Makefile
-       sed \
-               -e 's|@VERSION[@]|$(VERSION)|g' \
-       $< > $@
+BUILT_SOURCES = grc.conf
 
 grc.conf: $(srcdir)/grc.conf.in Makefile
        sed \