using gr copy in the wxgui connect, added gr copy to grc xml
[debian/gnuradio] / grc / Makefile.am
index 8b77fc31a5bba87b4b3c38283a5c854be4f347b1..28408c4a830e3f9d1c6e6aae6af38b73f451741a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008 Free Software Foundation, Inc.
+# Copyright 2008, 2009 Free Software Foundation, Inc.
 #
 # This file is part of GNU Radio
 #
 
 include $(top_srcdir)/grc/Makefile.inc
 
-SUBDIRS = $(XDG_UTILS) \
-       data \
+if PYTHON
+SUBDIRS = \
+       base \
+       blocks \
        examples \
-       scripts \
-       src
+       grc_gnuradio \
+       gui \
+       python \
+       scripts
+
+## append freedesktop to the list of subdirs when xdg utils are present
+if XDG_UTILS
+SUBDIRS += freedesktop
+endif
+
+ourpythondir = $(grc_src_prefix)
+ourpython_PYTHON = __init__.py
+
+etcdir = $(gr_prefsdir)
+dist_etc_DATA = grc.conf
+
+EXTRA_DIST = $(srcdir)/grc.conf.in
+
+BUILT_SOURCES = grc.conf
+
+grc.conf: $(srcdir)/grc.conf.in Makefile
+       sed \
+               -e 's|@pythonw[@]|$(PYTHONW)|g' \
+               -e 's|@blocksdir[@]|$(grc_blocksdir)|g' \
+               -e 's|@docdir[@]|$(gr_docdir)|g' \
+       $< > $@
+
+endif