Merged wxgui/forms branch r11124:11183
[debian/gnuradio] / gr-wxgui / src / python / Makefile.am
index 2d25de05b94589fec9d83906d978cd2db4da44e1..e06298a2d081b93ae561e93b421df0124e2b2e40 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005 Free Software Foundation, Inc.
+# Copyright 2004,2005,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
 
+SUBDIRS = plotter
+
 # Install this stuff so that it ends up as the gnuradio.wxgui module
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio/wxgui
@@ -30,11 +32,37 @@ ourlibdir    = $(grpyexecdir)/wxgui
 
 ourpython_PYTHON =                     \
        __init__.py                     \
+       common.py                       \
+       constants.py                    \
+       constsink_gl.py                 \
+       const_window.py                 \
        form.py                         \
-       fftsink.py                      \
+       fftsink2.py                     \
+       fftsink_nongl.py                \
+       fftsink_gl.py                   \
+       fft_window.py                   \
+       gui.py                          \
+       histosink_gl.py                 \
+       histo_window.py                 \
+       numbersink2.py                  \
+       number_window.py                \
        plot.py                         \
        powermate.py                    \
-       scopesink.py                    \
-       waterfallsink.py                \
+       pubsub.py                       \
+       scopesink2.py                   \
+       scopesink_nongl.py              \
+       scopesink_gl.py                 \
+       scope_window.py                 \
+       waterfallsink2.py               \
+       waterfallsink_nongl.py          \
+       waterfallsink_gl.py             \
+       waterfall_window.py             \
        slider.py                       \
-       stdgui.py                       
+       stdgui2.py
+
+formspythondir = $(grpythondir)/wxgui/forms
+
+formspython_PYTHON = \
+       forms/__init__.py \
+       forms/forms.py \
+       forms/converters.py