lower phase noise with lower cp current
[debian/gnuradio] / gr-usrp / src / Makefile.am
index 4b502f5daa7d6d791379f1956e88f831eb094270..26b7043a977ddaef0f866d96bcc50b30deeeee7a 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -15,8 +15,8 @@
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
@@ -32,7 +32,7 @@ EXTRA_DIST = run_tests.in
 TESTS = run_tests
 
 LOCAL_IFILES =                                 \
-       usrp1.i                         
+       $(top_srcdir)/gr-usrp/src/usrp1.i                               
 
 NON_LOCAL_IFILES = $(GNURADIO_I)
 
@@ -50,6 +50,8 @@ ourpython_PYTHON =                    \
        db_dbs_rx.py                    \
        db_flexrf.py                    \
        db_flexrf_mimo.py               \
+       db_wbx.py                       \
+       db_xcvr2450.py                  \
        db_instantiator.py              \
        db_tv_rx.py                     \
        flexrf_debug_gui.py             \
@@ -61,11 +63,14 @@ ourpython_PYTHON =                  \
 
 INCLUDES = $(STD_DEFINES_AND_INCLUDES)  \
           $(PYTHON_CPPFLAGS)           \
-          $(USRP_INCLUDES)
+          $(USRP_INCLUDES)             \
+          $(WITH_INCLUDES)
 
 SWIGPYTHONARGS = $(SWIGPYTHONFLAGS)         \
                 $(STD_DEFINES_AND_INCLUDES) \
-                $(USRP_INCLUDES)
+                $(USRP_INCLUDES)            \
+                $(WITH_INCLUDES)            \
+                $(WITH_SWIG_INCLUDES)
 
 grinclude_HEADERS =                    \
        usrp1_sink_base.h               \
@@ -94,16 +99,16 @@ _usrp1_la_SOURCES =                         \
 
 _usrp1_la_LIBADD =                     \
        $(PYTHON_LDFLAGS)               \
-       $(GNURADIO_CORE_LIBS)           \
-       $(USRP_LIBS)                    \
+       $(GNURADIO_CORE_LA)             \
+       $(USRP_LA)                      \
        -lstdc++
 
 
 _usrp1_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 
 
-usrp1.cc usrp1.py: usrp1.i $(NON_LOCAL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module usrp1 -o usrp1.cc $<
+usrp1.cc usrp1.py: usrp1.i $(NON_LOCAL_IFILES) $(LOCAL_IFILES)
+       $(SWIG) $(SWIGPYTHONARGS) -module usrp1 -o usrp1.cc $(LOCAL_IFILES)
 
 
 noinst_PYTHON =                                \