Fixes ticket:77.
[debian/gnuradio] / gr-trellis / src / lib / Makefile.am
index 1b3e66461b4a8a1fa00ac580ab330bb9116472ec..466ab6bb7bc784b3a6fd1ff2656a35e84a275727 100644 (file)
@@ -15,8 +15,8 @@
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
@@ -43,7 +43,7 @@ NON_LOCAL_IFILES =                    \
 
 
 LOCAL_IFILES =                                 \
-       trellis.i                       
+       $(top_srcdir)/gr-trellis/src/lib/trellis.i                      
 
 
 # These files are built by SWIG.  The first is the C++ glue.
@@ -65,13 +65,16 @@ _trellis_la_SOURCES =                       \
        trellis.cc                      \
         fsm.cc                         \
         quicksort_index.cc             \
+        base.cc                                \
         interleaver.cc                 \
         trellis_calc_metric.cc         \
         trellis_permutation.cc         \
+       trellis_siso_f.cc               \
+       trellis_siso_combined_f.cc      \
        $(GENERATED_CC)                 
 
 # magic flags
-_trellis_la_LDFLAGS = -module -avoid-version
+_trellis_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 
 # link the library against some comon swig runtime code and the 
 # c++ standard library
@@ -80,24 +83,40 @@ _trellis_la_LIBADD =                        \
        $(GNURADIO_CORE_LIBS)           \
        -lstdc++                        
 
-trellis.cc trellis.py: trellis.i $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module trellis -o trellis.cc $<
+trellis.cc trellis.py: $(ALL_IFILES) $(grinclude_HEADERS)
+       $(SWIG) $(SWIGPYTHONARGS) -module trellis -o trellis.cc $(LOCAL_IFILES)
 
 # These headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                    \
         fsm.h                          \
         quicksort_index.h              \
+        base.h                         \
         interleaver.h                  \
         trellis_metric_type.h          \
         trellis_calc_metric.h          \
         trellis_permutation.h          \
+        trellis_siso_type.h            \
+       trellis_siso_f.h                \
+       trellis_siso_combined_f.h               \
        $(GENERATED_H)                  
 
 
 # These swig headers get installed in ${prefix}/include/gnuradio/swig
 swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+       $(LOCAL_IFILES)                 \
+       $(GENERATED_I)                  \
+       fsm.i                           \
+       interleaver.i                   \
+       trellis_permutation.i           \
+       trellis_siso_f.i                \
+       trellis_siso_combined_f.i       \
+       trellis_generated.i
+
 
 
 MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
 
+# Don't distribute output of swig
+dist-hook:
+       @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
+       @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done