Merged r7866:7887 from michaelld/discheck_fix into trunk. Allows running 'make distc...
[debian/gnuradio] / gr-trellis / src / lib / Makefile.am
index d18fad8dba0ea8730b73927c92ff38cf9b17c6d4..9eeb3e043d6faf93b1a2b91490aa2e7078474292 100644 (file)
@@ -52,11 +52,12 @@ CODE_GENERATOR =                            \
        trellis_viterbi_X.h.t                   \
        trellis_viterbi_X.i.t
 
-include Makefile.gen
+include $(srcdir)/Makefile.gen
 
-$(GENERATED_H) $(GENERATED_I) $(GENERATED_CC): $(CODE_GENERATOR)
+$(srcdir)/Makefile.gen $(GENERATED_H) $(GENERATED_I) $(GENERATED_CC): $(CODE_GENERATOR)
        PYTHONPATH=$(top_srcdir)/gnuradio-core/src/python \
                srcdir=$(srcdir) $(PYTHON) $(srcdir)/generate_all.py
+       touch $(srcdir)/Makefile.in
 
 # These files are built by SWIG.  The first is the C++ glue.
 # The second is the python wrapper that loads the _trellis shared library