Merged r10504:10528 from michaelld/fix_local_data_install into trunk. Trunk passes...
[debian/gnuradio] / gr-sounder / src / fpga / top / Makefile.am
index 9498d434297ead9d28671ac9baa0731cc769338a..33e8c860d41f97950be828aaf3f66e14a1b891ed 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2007 Free Software Foundation, Inc.
+# Copyright 2007,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 
 include $(top_srcdir)/Makefile.common
 
-datadir = $(prefix)/share/usrp
+RBFS = usrp_sounder.rbf
+
+rbf2datadir = $(prefix)/share/usrp/rev2
+dist_rbf2data_DATA = $(RBFS)
+
+rbf4datadir = $(prefix)/share/usrp/rev4
+dist_rbf4data_DATA = $(RBFS)
 
 EXTRA_DIST =                   \
        config.vh               \
@@ -29,26 +35,7 @@ EXTRA_DIST =                 \
        usrp_sounder.csf        \
        usrp_sounder.esf        \
        usrp_sounder.psf        \
-       usrp_sounder.qpf        \
-       $(RBFS)
-
-RBFS =         usrp_sounder.rbf
-
-install-data-local:
-       @for file in $(RBFS); do \
-               echo "$(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(datadir)/rev2/$$file"; \
-               $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(datadir)/rev2/$$file; \
-               echo "$(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(datadir)/rev4/$$file"; \
-               $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(datadir)/rev4/$$file; \
-       done
-
-uninstall-local:
-       @for file in $(rbfs); do \
-               echo "$(RM) $(DESTDIR)$(datadir)/rev2/$$file"; \
-               $(RM) $(DESTDIR)$(datadir)/rev2/$$file; \
-               echo "$(RM) $(DESTDIR)$(datadir)/rev4/$$file"; \
-               $(RM) $(DESTDIR)$(datadir)/rev4/$$file; \
-       done
+       usrp_sounder.qpf
 
 MOSTLYCLEANFILES =     \
        db/*            \
@@ -60,4 +47,3 @@ MOSTLYCLEANFILES =    \
        *.pin           \
        *.sof           \
        *~
-