More fixes for ticket:35, which was reopened.
[debian/gnuradio] / gr-radio-astronomy / src / lib / Makefile.am
index 375c169ae0e18d5cdfcaa1f60571084cdd7cd7aa..f670ba4237eeb3b00f27d86c9b2740f77cf8784f 100644 (file)
@@ -40,7 +40,7 @@ NON_LOCAL_IFILES =                    \
        $(GNURADIO_I)
 
 LOCAL_IFILES =                                 \
-       ra.i                            
+       $(top_srcdir)/gr-radio-astronomy/src/lib/ra.i                           
 
 # These files are built by SWIG.  The first is the C++ glue.
 # The second is the python wrapper that loads the _howto shared library
@@ -70,8 +70,8 @@ _ra_la_LIBADD =                       \
        $(GNURADIO_CORE_LIBS)           \
        -lstdc++                        
 
-ra.cc ra.py: ra.i $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module ra -o ra.cc $<
+ra.cc ra.py: $(ALL_IFILES)
+       $(SWIG) $(SWIGPYTHONARGS) -module ra -o ra.cc $(LOCAL_IFILES)
 
 # These headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =