Removing Waterfall3DPlot. The qwt_plot3d is too much of a hassle to deal with and...
[debian/gnuradio] / gr-qtgui / src / lib / Makefile.am
index 6c90c31f0f946687b15ceb65ae79d721de794ec6..bd9c945bc948c8dd74aea5f7497c31fc2836ef2c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008,2009 Free Software Foundation, Inc.
+# Copyright 2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -31,7 +31,6 @@ QMAKE_SOURCES =                               \
        FrequencyDisplayPlot_moc.cc             \
        TimeDomainDisplayPlot_moc.cc            \
        WaterfallDisplayPlot_moc.cc             \
-       Waterfall3DDisplayPlot_moc.cc           \
        ConstellationDisplayPlot_moc.cc         \
        spectrumdisplayform_ui.h
 
@@ -47,14 +46,12 @@ libgnuradio_qtgui_la_SOURCES =      \
        FrequencyDisplayPlot.cc                 \
        TimeDomainDisplayPlot.cc                \
        WaterfallDisplayPlot.cc                 \
-       Waterfall3DDisplayPlot.cc               \
        waterfallGlobalData.cc                  \
        ConstellationDisplayPlot.cc             \
        spectrumdisplayform.cc                  \
        SpectrumGUIClass.cc                     \
        spectrumUpdateEvents.cc                 \
        plot_waterfall.cc                       \
-       $(QMAKE_SOURCES)                        \
        qtgui_sink_c.cc                         \
        qtgui_sink_f.cc
 
@@ -63,7 +60,6 @@ grinclude_HEADERS =                   \
        FrequencyDisplayPlot.h          \
        TimeDomainDisplayPlot.h         \
        WaterfallDisplayPlot.h          \
-       Waterfall3DDisplayPlot.h        \
        waterfallGlobalData.h           \
        ConstellationDisplayPlot.h      \
        highResTimeFunctions.h          \
@@ -82,7 +78,7 @@ grinclude_HEADERS =                   \
        $(QT_UIC_EXEC) $< -o $@
 
 # magic flags
-libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
 libgnuradio_qtgui_la_LIBADD =          \
        $(GNURADIO_CORE_LA)     \
@@ -112,7 +108,8 @@ include $(top_srcdir)/Makefile.swig
 # add some of the variables generated inside the Makefile.swig.gen
 BUILT_SOURCES +=               \
        $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
 endif
+
+# Do not distribute built sources, they may contain generated paths
+# which are invalid on other systems
+no_dist_files = $(BUILT_SOURCES)