Merge branch 'maint'
[debian/gnuradio] / gr-qtgui / src / lib / Makefile.am
index eee58990d890955cb1820e3c8a6cd1869ccc170e..6d4a91257bfef9a6970529df98b71c3f2b3e98e6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008,2009 Free Software Foundation, Inc.
+# Copyright 2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -26,7 +26,6 @@ AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
 
 # Only include these files in the build if qtgui passes configure checks
 # This is mostly to help make distcheck pass
-if BUILD_QT
 QMAKE_SOURCES =                                \
        spectrumdisplayform_moc.cc              \
        FrequencyDisplayPlot_moc.cc             \
@@ -35,15 +34,16 @@ QMAKE_SOURCES =                             \
        Waterfall3DDisplayPlot_moc.cc           \
        ConstellationDisplayPlot_moc.cc         \
        spectrumdisplayform_ui.h
-endif
 
 EXTRA_DIST = spectrumdisplayform.ui
 
+BUILT_SOURCES = $(QMAKE_SOURCES)
+
 # Build the normal library for C++ apps to link against
-lib_LTLIBRARIES = libqtgui.la
+lib_LTLIBRARIES = libgnuradio-qtgui.la
 
 # These are the source files that go into the shared library
-libqtgui_la_SOURCES =  \
+libgnuradio_qtgui_la_SOURCES =         \
        FrequencyDisplayPlot.cc                 \
        TimeDomainDisplayPlot.cc                \
        WaterfallDisplayPlot.cc                 \
@@ -54,7 +54,6 @@ libqtgui_la_SOURCES =         \
        SpectrumGUIClass.cc                     \
        spectrumUpdateEvents.cc                 \
        plot_waterfall.cc                       \
-       $(QMAKE_SOURCES)                        \
        qtgui_sink_c.cc                         \
        qtgui_sink_f.cc
 
@@ -75,28 +74,23 @@ grinclude_HEADERS =                 \
        qtgui_sink_c.h                  \
        qtgui_sink_f.h
 
-if BUILD_QT
-%_moc.cc : %.h
-       $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB $< -o $@
+nodist_libqtsrc_la_SOURCES = $(QMAKE_SOURCES)
 
-%_ui.h : %.ui
-       $(QT_UIC_EXEC) $< -o $@
-else
 %_moc.cc : %.h
-       touch $@
+       $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@
 
 %_ui.h : %.ui
-       touch $@
-endif
+       $(QT_UIC_EXEC) $< -o $@
 
 # magic flags
-libqtgui_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
-libqtgui_la_LIBADD =           \
+libgnuradio_qtgui_la_LIBADD =          \
        $(GNURADIO_CORE_LA)     \
        -lstdc++                \
        $(QT_LIBS)
 
+if PYTHON
 ##############################
 # SWIG interface and library
 
@@ -108,18 +102,19 @@ TOP_SWIG_IFILES =                 \
 # This ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
 qtgui_pythondir_category =     \
-       gnuradio
+       gnuradio/qtgui
 
 # additional libraries for linking with the SWIG-generated library
 qtgui_la_swig_libadd =         \
-       libqtgui.la
+       libgnuradio-qtgui.la
 
 include $(top_srcdir)/Makefile.swig
 
 # add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES =                \
-       $(QMAKE_SOURCES)        \
+BUILT_SOURCES +=               \
        $(swig_built_sources)
+endif
 
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+# Do not distribute built sources, they may contain generated paths
+# which are invalid on other systems
+no_dist_files = $(BUILT_SOURCES)