Merge branch 'maint'
[debian/gnuradio] / gr-qtgui / src / lib / Makefile.am
index 6c90c31f0f946687b15ceb65ae79d721de794ec6..6d4a91257bfef9a6970529df98b71c3f2b3e98e6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2008,2009 Free Software Foundation, Inc.
+# Copyright 2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
@@ -54,7 +54,6 @@ libgnuradio_qtgui_la_SOURCES =        \
        SpectrumGUIClass.cc                     \
        spectrumUpdateEvents.cc                 \
        plot_waterfall.cc                       \
-       $(QMAKE_SOURCES)                        \
        qtgui_sink_c.cc                         \
        qtgui_sink_f.cc
 
@@ -75,6 +74,8 @@ grinclude_HEADERS =                   \
        qtgui_sink_c.h                  \
        qtgui_sink_f.h
 
+nodist_libqtsrc_la_SOURCES = $(QMAKE_SOURCES)
+
 %_moc.cc : %.h
        $(QT_MOC_EXEC) -DQT_SHARED -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_GUI_LIB -DQT_CORE_LIB -p $(srcdir) $< -o $@
 
@@ -82,7 +83,7 @@ grinclude_HEADERS =                   \
        $(QT_UIC_EXEC) $< -o $@
 
 # magic flags
-libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
+libgnuradio_qtgui_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
 libgnuradio_qtgui_la_LIBADD =          \
        $(GNURADIO_CORE_LA)     \
@@ -112,7 +113,8 @@ include $(top_srcdir)/Makefile.swig
 # add some of the variables generated inside the Makefile.swig.gen
 BUILT_SOURCES +=               \
        $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
 endif
+
+# Do not distribute built sources, they may contain generated paths
+# which are invalid on other systems
+no_dist_files = $(BUILT_SOURCES)