Adds callback function so that the user can click on a point in the time sequence...
[debian/gnuradio] / gr-pager / src / Makefile.am
index b82e34dca163c09c68d87829773135942a59500d..5c70db2f5a2bff3b9f7f8e89d34489b3736fa5e3 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 include $(top_srcdir)/Makefile.common
 
 EXTRA_DIST = \
-    run_tests.in
+    run_tests.in \
+    $(bin_SCRIPTS)
 
 TESTS = \
     run_tests
 
 bin_SCRIPTS = \
     usrp_flex.py \
-    aypabtu.py 
-    
+    usrp_flex_all.py \
+    usrp_flex_band.py
+
 noinst_PYTHON = \
     qa_pager.py
 
@@ -41,9 +43,10 @@ noinst_PYTHON = \
 ourpythondir = $(grpythondir)/pager
 ourlibdir    = $(grpyexecdir)/pager
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES) \
+       $(WITH_SWIG_INCLUDES) $(WITH_INCLUDES)
 
 ALL_IFILES = \
     $(LOCAL_IFILES) \
@@ -64,14 +67,12 @@ BUILT_SOURCES = \
     pager_swig.cc \
     pager_swig.py                              
 
-# This gets pgr.py installed in the right place
+# This gets imported Python objects installed in the right place
 ourpython_PYTHON = \
     __init__.py \
     pager_swig.py \
-    flex_demod.py \
-    usrp_flex.py \
-    aypabtu.py
-    
+    flex_demod.py
+        
 ourlib_LTLIBRARIES = _pager_swig.la
 
 # These are the source files that go into the shared library
@@ -93,7 +94,7 @@ _pager_swig_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 # link the library against the c++ standard library
 _pager_swig_la_LIBADD = \
     $(PYTHON_LDFLAGS) \
-    $(GNURADIO_CORE_LIBS) \
+    $(GNURADIO_CORE_LA) \
     -lstdc++                   
 
 pager_swig.cc pager_swig.py: $(ALL_IFILES)