Merge branch 'fll'
[debian/gnuradio] / gr-msdd6000 / src / Makefile.am
index dbf1271ed0f53dac01076838028af86c88c2db97..7744395f34cac4dff90bc424bc48907b2a165e36 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2007,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # the Free Software Foundation, Inc., 51 Franklin Street,
 # Boston, MA 02110-1301, USA.
 # 
-CCFLAGS = -g
-include $(top_srcdir)/Makefile.common
-
-# Install this stuff so that it ends up as the gnuradio.howto module
-# This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio
 
-ourpythondir = $(grpythondir)
-ourlibdir    = $(grpyexecdir)
-
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(SWIGGRFLAGS)
+include $(top_srcdir)/Makefile.common
 
-ALL_IFILES =                           \
-       $(LOCAL_IFILES)                 \
-       $(NON_LOCAL_IFILES)             
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
+       $(WITH_INCLUDES)
 
-NON_LOCAL_IFILES =                     \
-       $(GNURADIO_CORE_INCLUDEDIR)/swig/gnuradio.i
+# C/C++ headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS =                    \
+       msdd_source_simple.h            \
+       msdd_buffer_copy_behaviors.h    \
+       msdd6000.h                      \
+       msdd_rs_source_simple.h         \
+       msdd6000_rs.h
 
+lib_LTLIBRARIES = libgnuradio-msdd6000.la \
+       libgnuradio-msdd6000_rs.la
 
-LOCAL_IFILES =                                 \
-       $(top_srcdir)/src/msdd/msdd.i                           
+libgnuradio_msdd6000_la_SOURCES =      \
+       msdd_source_simple.cc           \
+       msdd6000.cc
 
-# These files are built by SWIG.  The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
 
-BUILT_SOURCES =                        \
-       msdd.cc                 \
-       msdd.py                         
+libgnuradio_msdd6000_rs_la_SOURCES =   \
+       msdd_rs_source_simple.cc                \
+       msdd6000_rs.cc
 
-# This gets howto.py installed in the right place
-ourpython_PYTHON =                     \
-       msdd.py
+libgnuradio_msdd6000_la_LIBADD =       \
+       $(GNURADIO_CORE_LA)
 
-ourlib_LTLIBRARIES = _msdd.la
+libgnuradio_msdd6000_la_LDFLAGS =      \
+       $(NO_UNDEFINED)
 
-# These are the source files that go into the shared library
-_msdd_la_SOURCES =                     \
-       msdd.cc                 \
-       msdd_source_base.cc     \
-       msdd_source_c.cc        \
-       msdd_source_simple.cc   \
-       msdd_source_s.cc        \
-       msdd6000.cc
+libgnuradio_msdd6000_rs_la_LIBADD =    \
+       $(GNURADIO_CORE_LA)
 
-# magic flag
-_msdd_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version 
-#-lfftw3 -lfftw3f -lfann 
+libgnuradio_msdd6000_rs_la_LDFLAGS =   \
+       $(NO_UNDEFINED)
 
-# link the library against some comon swig runtime code and the 
-# c++ standard library
-_msdd_la_LIBADD =                      \
-       $(PYTHON_LDFLAGS)               \
-       -lstdc++
-# -L/usr/lib/libfftw3f.so.3.1.2
+if PYTHON
+#################################
+# SWIG interface and library
 
-msdd.cc msdd.py: $(LOCAL_IFILES) $(ALL_IFILES) 
-       $(SWIG) $(SWIGPYTHONARGS) -module msdd -o msdd.cc $(LOCAL_IFILES)
+TOP_SWIG_IFILES =                      \
+       msdd.i msdd_rs.i
 
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS =                    \
-       msdd_source_base.h              \
-       msdd_source_c.h                 \
-       msdd_source_simple.h                    \
-       msdd_source_s.h                 
+# Install so that they end up available as:
+#   import gnuradio.msdd
+# This ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/gnuradio
+msdd_pythondir_category =              \
+       gnuradio
 
+msdd_rs_pythondir_category =   \
+       gnuradio
 
+# additional libraries for linking with the SWIG-generated library
+msdd_la_swig_libadd =                  \
+       libgnuradio-msdd6000.la
 
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+msdd_rs_la_swig_libadd =                       \
+       libgnuradio-msdd6000_rs.la
 
+include $(top_srcdir)/Makefile.swig
 
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
 
-# Don't distribute output of swig
-dist-hook:
-       @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
-       @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+endif