Let's step into the 21st century...
[debian/gnuradio] / gr-howto-write-a-block / configure.ac
index 7035599d5309d5c6077985467028460b106332bf..8b1a10f69bf8a2af66cf023112802cf14e850641 100644 (file)
@@ -1,11 +1,11 @@
 dnl 
-dnl  Copyright 2004,2005 Free Software Foundation, Inc.
+dnl  Copyright 2004,2005,2007 Free Software Foundation, Inc.
 dnl  
 dnl  This file is part of GNU Radio
 dnl  
 dnl  GNU Radio is free software; you can redistribute it and/or modify
 dnl  it under the terms of the GNU General Public License as published by
-dnl  the Free Software Foundation; either version 2, or (at your option)
+dnl  the Free Software Foundation; either version 3, or (at your option)
 dnl  any later version.
 dnl  
 dnl  GNU Radio is distributed in the hope that it will be useful,
@@ -24,7 +24,7 @@ AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/lib/howto.i])
 AM_CONFIG_HEADER(config.h)
 AC_CANONICAL_TARGET([])
-AM_INIT_AUTOMAKE(gr-howto-write-a-block,3.0svn)
+AM_INIT_AUTOMAKE(gr-howto-write-a-block,3.1.svn)
 
 GR_X86_64
 dnl LF_CONFIGURE_CC
@@ -32,10 +32,11 @@ LF_CONFIGURE_CXX
 LF_SET_WARNINGS
 GR_SET_GPROF
 GR_SET_PROF
-GR_PROG_AS
+AM_PROG_AS
 AC_PROG_LN_S
 AC_PROG_MAKE_SET
 AC_PROG_INSTALL
+AC_PATH_PROG([RM_PROG], [rm])
 
 AC_LIBTOOL_WIN32_DLL
 AC_ENABLE_SHARED       dnl do build shared libraries
@@ -78,7 +79,7 @@ AC_CHECK_FUNCS([])
 dnl Check for Mingw support
 GR_PWIN32
 
-PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 2)
+PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 3)
 LIBS="$LIBS $GNURADIO_CORE_LIBS"
 
 dnl Define where to find boost includes