libtool 2.2 compatibility fix from Don Ward. Details in ticket:249.
[debian/gnuradio] / gr-howto-write-a-block / configure.ac
index 0d29475809905a7cea7b491ea18d15f51004a30c..4137858a0ed7521355e4f2f9af64448d470ed3de 100644 (file)
@@ -1,11 +1,11 @@
 dnl 
-dnl  Copyright 2004,2005 Free Software Foundation, Inc.
+dnl  Copyright 2004,2005,2007 Free Software Foundation, Inc.
 dnl  
 dnl  This file is part of GNU Radio
 dnl  
 dnl  GNU Radio is free software; you can redistribute it and/or modify
 dnl  it under the terms of the GNU General Public License as published by
-dnl  the Free Software Foundation; either version 2, or (at your option)
+dnl  the Free Software Foundation; either version 3, or (at your option)
 dnl  any later version.
 dnl  
 dnl  GNU Radio is distributed in the hope that it will be useful,
@@ -24,7 +24,7 @@ AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/lib/howto.i])
 AM_CONFIG_HEADER(config.h)
 AC_CANONICAL_TARGET([])
-AM_INIT_AUTOMAKE(gr-howto-write-a-block,0.6cvs)
+AM_INIT_AUTOMAKE(gr-howto-write-a-block,3.1.svn)
 
 GR_X86_64
 dnl LF_CONFIGURE_CC
@@ -32,15 +32,16 @@ LF_CONFIGURE_CXX
 LF_SET_WARNINGS
 GR_SET_GPROF
 GR_SET_PROF
-GR_PROG_AS
+AM_PROG_AS
 AC_PROG_LN_S
 AC_PROG_MAKE_SET
 AC_PROG_INSTALL
+AC_PATH_PROG([RM_PROG], [rm])
 
 AC_LIBTOOL_WIN32_DLL
 AC_ENABLE_SHARED       dnl do build shared libraries
 AC_DISABLE_STATIC      dnl don't build static libraries
-AC_PROG_LIBTOOL
+m4_ifdef([LT_INIT],[LT_INIT],[AC_PROG_LIBTOOL])
 
 dnl Locate python, SWIG, etc
 GR_NO_UNDEFINED
@@ -78,7 +79,7 @@ AC_CHECK_FUNCS([])
 dnl Check for Mingw support
 GR_PWIN32
 
-PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 2)
+PKG_CHECK_MODULES(GNURADIO_CORE, gnuradio-core >= 3)
 LIBS="$LIBS $GNURADIO_CORE_LIBS"
 
 dnl Define where to find boost includes