Merge commit 'v3.3.0' into upstream
[debian/gnuradio] / gr-howto-write-a-block / config / Makefile.am
index 7fdaba2ee617d1c3c4f4191a58ea0584df1655c9..23f4a4b16e68fa10ea6cb394bd92d91f9285b242 100644 (file)
@@ -5,7 +5,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -25,39 +25,56 @@ include $(top_srcdir)/Makefile.common
 m4datadir = $(datadir)/aclocal
 
 # List your m4 macros here
-m4macros =                     \
-       acx_pthread.m4          \
-       bnv_have_qt.m4          \
-       cppunit.m4              \
-       gr_as.m4                \
-       gr_boost.m4             \
+m4macros = \
+       acx_pthread.m4 \
+       ax_boost_base.m4 \
+       ax_boost_date_time.m4 \
+       ax_boost_filesystem.m4 \
+       ax_boost_iostreams.m4 \
+       ax_boost_program_options.m4 \
+       ax_boost_python.m4 \
+       ax_boost_regex.m4 \
+       ax_boost_serialization.m4 \
+       ax_boost_signals.m4 \
+       ax_boost_system.m4 \
+       ax_boost_test_exec_monitor.m4 \
+       ax_boost_thread.m4 \
+       ax_boost_unit_test_framework.m4 \
+       ax_boost_wserialization.m4 \
+       bnv_have_qt.m4 \
+       cppunit.m4 \
        gr_check_createfilemapping.m4 \
-       gr_check_usrp.m4        \
-       gr_check_mc4020.m4      \
-       gr_check_shm_open.m4    \
-       gr_doxygen.m4           \
-       gr_gprof.m4             \
+       gr_check_mc4020.m4 \
+       gr_check_shm_open.m4 \
+       gr_check_usrp.m4 \
+       gr_doxygen.m4 \
+       gr_fortran.m4 \
+       gr_git.m4 \
+       gr_gprof.m4 \
+       gr_lib64.m4 \
        gr_libgnuradio_core_extra_ldflags.m4 \
-       gr_no_undefined.m4      \
-       gr_omnithread.m4        \
-       gr_pwin32.m4            \
-       gr_python.m4            \
-       gr_require_mc4020.m4    \
-       gr_scripting.m4         \
-       gr_set_md_cpu.m4        \
-       gr_swig.m4              \
-       gr_sysv_shm.m4          \
-       gr_x86_64.m4            \
-       lf_cc.m4                \
-       lf_cxx.m4               \
-       lf_warnings.m4          \
-       lf_x11.m4               \
-       mkstemp.m4              \
-       onceonly.m4             \
-       pkg.m4                  \
-       usrp_fusb_tech.m4       \
-       usrp_libusb.m4          \
-       usrp_sdcc.m4            
+       gr_no_undefined.m4 \
+       gr_omnithread.m4 \
+       gr_pwin32.m4 \
+       gr_python.m4 \
+       gr_require_mc4020.m4 \
+       gr_scripting.m4 \
+       gr_set_md_cpu.m4 \
+       gr_standalone.m4 \
+       gr_subversion.m4 \
+       gr_swig.m4 \
+       gr_sysv_shm.m4 \
+       gr_version.m4 \
+       lf_cc.m4 \
+       lf_cxx.m4 \
+       lf_warnings.m4 \
+       lf_x11.m4 \
+       mkstemp.m4 \
+       onceonly.m4 \
+       pkg.m4 \
+       usrp_fusb_tech.m4 \
+       usrp_libusb.m4 \
+       usrp_sdcc.m4
 
 
 # Don't install m4 macros anymore