Search for rm, and substitute it. Avoids assumption that make
[debian/gnuradio] / gr-howto-write-a-block / Makefile.common
index 31a31232a782b122e40b58abf631407468c49617..0160c354a2ec66b44b4a5a553c9690974d56bc68 100644 (file)
@@ -36,3 +36,8 @@ grpyexecdir = $(pyexecdir)/gnuradio
 # swig flags
 SWIGPYTHONFLAGS = -fvirtual -python -modern
 SWIGGRFLAGS = -I$(GNURADIO_CORE_INCLUDEDIR)/swig -I$(GNURADIO_CORE_INCLUDEDIR)
+
+# Don't assume that make predefines $(RM), because BSD make does
+# not. We define it now in configure.ac using AM_PATH_PROG, but now
+# here have to add a -f to be like GNU make.
+RM=$(RM_PROG) -f