howto: added howto application
[debian/gnuradio] / gr-howto-write-a-block / Makefile.am
index c16bd979e7b23ce23172471656870ac521bfd6b1..50551ed5082c72c74d1db988f9c1049ddb1cc740 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # Boston, MA 02110-1301, USA.
 # 
 
+ACLOCAL_AMFLAGS = -I config
+
 include $(top_srcdir)/Makefile.common
 
-EXTRA_DIST = bootstrap configure config.h.in .buildpri
-SUBDIRS = config src
-DIST_SUBDIRS = config src doc
+EXTRA_DIST = \
+       bootstrap \
+       configure \
+       config.h.in \
+       Makefile.swig \
+       Makefile.swig.gen.t \
+       version.sh
+
+SUBDIRS = config lib swig python grc apps
 
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA =
+
+DISTCLEANFILES = gr-howto-write-a-block*.tar.gz