Merge commit 'v3.3.1' into try-3.3.1
[debian/gnuradio] / gr-gsm-fr-vocoder / src / lib / Makefile.am
index 90159dc96986dbe94eff31c82910f75696e7303c..97d6fc30690a36bef975020d85575fae2bc1974e 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005 Free Software Foundation, Inc.
+# Copyright 2004,2005,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -23,79 +23,46 @@ include $(top_srcdir)/Makefile.common
 
 SUBDIRS = gsm .
 
-# Install this stuff so that it ends up as the gnuradio.vocoder module
-# This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
-
-ourpythondir = $(grpythondir)/vocoder
-ourlibdir    = $(grpyexecdir)/vocoder
-
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
-
-
-ALL_IFILES =                           \
-       $(LOCAL_IFILES)                 \
-       $(NON_LOCAL_IFILES)             
-
-NON_LOCAL_IFILES =                     \
-       $(GNURADIO_I)
-
-
-LOCAL_IFILES =                                 \
-       $(top_srcdir)/gr-gsm-fr-vocoder/src/lib/gsm_full_rate.i                         
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
-# These files are built by SWIG.  The first is the C++ glue.
-# The second is the python wrapper that loads the _howto shared library
-# and knows how to call our extensions.
-
-BUILT_SOURCES =                        \
-       gsm_full_rate.cc                \
-       gsm_full_rate.py                                
-
-# This gets gsm_full_rate.py installed in the right place
-ourpython_PYTHON =                     \
-       __init__.py                     \
-       gsm_full_rate.py
+# C/C++ headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS =                    \
+       gsm_fr_decode_ps.h              \
+       gsm_fr_encode_sp.h
 
-ourlib_LTLIBRARIES = _gsm_full_rate.la
+lib_LTLIBRARIES = libgnuradio-gsm-fr-vocoder.la
 
-# These are the source files that go into the shared library
-_gsm_full_rate_la_SOURCES =            \
+libgnuradio_gsm_fr_vocoder_la_SOURCES = \
        gsm_fr_decode_ps.cc             \
-       gsm_fr_encode_sp.cc             \
-       gsm_full_rate.cc                
-
+       gsm_fr_encode_sp.cc
 
-# magic flags
-_gsm_full_rate_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
+libgnuradio_gsm_fr_vocoder_la_LIBADD = \
+       $(GNURADIO_CORE_LA)             \
+       gsm/libgsm.la
 
-# link the library against the gsm library and the
-# c++ standard library
-_gsm_full_rate_la_LIBADD =     \
-       gsm/libgsm.la           \
-       $(PYTHON_LDFLAGS)       \
-       $(GNURADIO_CORE_LIBS)   \
-       -lstdc++                        
+libgnuradio_gsm_fr_vocoder_la_LDFLAGS =        $(NO_UNDEFINED) $(LTVERSIONFLAGS)
 
-gsm_full_rate.cc gsm_full_rate.py: gsm_full_rate.i $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module gsm_full_rate -o gsm_full_rate.cc $(LOCAL_IFILES)
+if PYTHON
+# SWIG interface and library
+TOP_SWIG_IFILES =                      \
+       gsm_full_rate.i
 
-# These headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS =                    \
-       gsm_fr_decode_ps.h              \
-       gsm_fr_encode_sp.h              
-
-# These swig headers get installed in ${prefix}/include/gnuradio/swig
-swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+# Install so that they end up available as:
+#   import gnuradio.vocoder.gsm_full_rate
+# This ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/gnuradio/vocoder
+gsm_full_rate_pythondir_category =     \
+       gnuradio/vocoder
 
+# additional libraries for linking with the SWIG-generated library
+gsm_full_rate_la_swig_libadd =         \
+       libgnuradio-gsm-fr-vocoder.la
 
-MOSTLYCLEANFILES = $(BUILT_SOURCES) *.pyc
+include $(top_srcdir)/Makefile.swig
 
-# Don't distribute output of swig
-dist-hook:
-       @for file in $(BUILT_SOURCES); do echo $(RM) $(distdir)/$$file; done
-       @for file in $(BUILT_SOURCES); do $(RM) $(distdir)/$$file; done
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
 
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+endif