More fixes for ticket:35, which was reopened.
[debian/gnuradio] / gr-ezdop / src / lib / Makefile.am
index b22d134ecc3fadeb7428e07f6958734160a23a14..4f301ec7c5833514d75e745461b701c80e9ea674 100644 (file)
@@ -50,7 +50,7 @@ NON_LOCAL_IFILES =                    \
 
 
 LOCAL_IFILES =                                 \
-       ezdop.i                         
+       $(top_srcdir)/gr-ezdop/src/lib/ezdop.i                          
 
 # These files are built by SWIG.  The first is the C++ glue.
 # The second is the python wrapper that loads the _ezdop shared library
@@ -83,7 +83,7 @@ _ezdop_la_LIBADD =                    \
        -lstdc++                        
 
 ezdop.cc ezdop.py: $(ALL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module ezdop -o ezdop.cc $<
+       $(SWIG) $(SWIGPYTHONARGS) -module ezdop -o ezdop.cc $(LOCAL_IFILES)
 
 # These headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                    \