Make C++ shared libraries versioned
[debian/gnuradio] / gr-audio-windows / src / Makefile.am
index f55110b8ac6a5522e03ce43f6fc10b814ccdee87..d3e3f5a85b0f0ade0f29d8e53211b93433935ce5 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005 Free Software Foundation, Inc.
+# Copyright 2004,2005,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
 
-# Install this stuff so that it ends up as the gnuradio.audio_windows module
-# This usually ends up at:
-#   ${prefix}/lib/python${python_version}/site-packages/gnuradio
-
-ourpythondir = $(grpythondir)
-ourlibdir    = $(grpyexecdir)
-
 EXTRA_DIST = run_tests.in
-TESTS = run_tests
-
-LOCAL_IFILES =                                 \
-       $(top_srcdir)/gr-audio-windows/src/audio_windows.i                              
-
-NON_LOCAL_IFILES =                     \
-       $(GNURADIO_I)
-
-ALL_IFILES =                           \
-       $(LOCAL_IFILES)                 \
-       $(NON_LOCAL_IFILES)             
-
-BUILT_SOURCES =                        \
-       audio_windows.cc                        \
-       audio_windows.py                                
 
-ourpython_PYTHON =                     \
-       audio_windows.py
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+noinst_PYTHON = qa_audio_windows.py
 
-SWIGCPPPYTHONARGS = -python $(PYTHON_CPPFLAGS) $(STD_DEFINES_AND_INCLUDES)
+# C/C++ headers get installed in ${prefix}/include/gnuradio
+grinclude_HEADERS =                    \
+       audio_windows_sink.h            \
+       audio_windows_source.h
 
-ourlib_LTLIBRARIES = _audio_windows.la
+lib_LTLIBRARIES = libgnuradio-audio-windows.la
 
-_audio_windows_la_SOURCES =            \
-       audio_windows.cc                        \
+libgnuradio_audio_windows_la_SOURCES =         \
        audio_windows_sink.cc           \
-       audio_windows_source.cc                 
+       audio_windows_source.cc         
 
+libgnuradio_audio_windows_la_LIBADD =  \
+       $(GNURADIO_CORE_LA)             \
+       $(WINAUDIO_LIBS)
 
-grinclude_HEADERS =                    \
-       audio_windows_sink.h            \
-       audio_windows_source.h                  
+libgnuradio_audio_windows_la_LDFLAGS = \
+       $(LIBGNURADIO_CORE_EXTRA_LDFLAGS) \
+       $(NO_UNDEFINED) \
+       $(LTVERSIONFLAGS)
 
-swiginclude_HEADERS =                  \
-       $(LOCAL_IFILES)
+if PYTHON
+###################################
+# SWIG Python interface and library
+TESTS = run_tests
+DISTCLEANFILES = run_tests
 
-_audio_windows_la_LIBADD =             \
-       $(PYTHON_LDFLAGS)               \
-       $(GNURADIO_CORE_LIBS)           \
-       $(WINAUDIO_LIBS)                \
-       -lstdc++                                
+TOP_SWIG_IFILES =                      \
+       audio_windows.i
 
-_audio_windows_la_LDFLAGS = -no-undefined -module -avoid-version \
-                            $(LIBGNURADIO_CORE_EXTRA_LDFLAGS)
+# Install so that they end up available as:
+#   import gnuradio.audio_windows
+# This ends up at:
+#   ${prefix}/lib/python${python_version}/site-packages/gnuradio
+audio_windows_pythondir_category =     \
+       gnuradio
 
-audio_windows.cc audio_windows.py: $(LOCAL_IFILES)
-       $(SWIG) $(SWIGCPPPYTHONARGS) -module audio_windows -o audio_windows.cc $(LOCAL_IFILES)
+# additional libraries for linking with the SWIG-generated library
+audio_windows_la_swig_libadd =         \
+       libgnuradio-audio-windows.la
 
+include $(top_srcdir)/Makefile.swig
 
-noinst_PYTHON = qa_audio_windows.py
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
 
-MOSTLYCLEANFILES = \
-       $(BUILT_SOURCES) *~ *.pyc
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+endif