Merged r10385:10413 from michaelld/swig_tweaks into trunk. Passes distcheck.
[debian/gnuradio] / gr-audio-oss / src / Makefile.am
index 656d665a774b63189baea9c46de160193cb1d1ca..eb038a977ea0af5adb24ecc2e9cc21c4a6c76dfd 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
 
-LIBS += $(GNURADIO_CORE_LIBS)
-
 # Install this stuff so that it ends up as the gnuradio.audio_oss module
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
@@ -34,10 +32,10 @@ EXTRA_DIST = run_tests.in
 TESTS = run_tests
 
 LOCAL_IFILES =                                 \
-       audio_oss.i                             
+       $(srcdir)/audio_oss.i
 
 NON_LOCAL_IFILES =                     \
-       $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+       $(GNURADIO_I)
 
 ALL_IFILES =                           \
        $(LOCAL_IFILES)                 \
@@ -50,33 +48,35 @@ BUILT_SOURCES =                     \
 ourpython_PYTHON =                     \
        audio_oss.py
 
-INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
-
-SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
 
 ourlib_LTLIBRARIES = _audio_oss.la
 
 _audio_oss_la_SOURCES =                \
        audio_oss.cc                    \
        audio_oss_sink.cc               \
-       audio_oss_source.cc                     
-
+       audio_oss_source.cc
 
 grinclude_HEADERS =                    \
        audio_oss_sink.h                \
-       audio_oss_source.h                      
+       audio_oss_source.h      
 
 swiginclude_HEADERS =                  \
        $(LOCAL_IFILES)
 
 _audio_oss_la_LIBADD =                         \
        $(PYTHON_LDFLAGS)               \
-       -lstdc++                                
+       $(GNURADIO_CORE_LA)             \
+       $(OSS_LIBS)                     \
+       -lstdc++
 
 _audio_oss_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 
-audio_oss.cc audio_oss.py: audio_oss.i $(NON_LOCAL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module audio_oss -o audio_oss.cc $<
+_audio_oss_la_CXXFLAGS = @swig_CXXFLAGS@
+
+audio_oss.cc audio_oss.py: $(ALL_IFILES)
+       $(SWIG) $(STD_SWIG_PYTHON_ARGS) -module audio_oss \
+               -o audio_oss.cc $(LOCAL_IFILES)
 
 # Don't distribute output of swig
 dist-hook: