bugfix for indexnumbers in IIR filter
[debian/gnuradio] / gr-audio-oss / src / Makefile.am
index 1a73d8d4c02df7bce115d5131886c82c8737b4d4..72707d99518404184dcc16dd8c863e9bebd51ade 100644 (file)
@@ -5,7 +5,7 @@
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
 include $(top_srcdir)/Makefile.common
 
-LIBS += $(GNURADIO_CORE_LIBS)
-
 # Install this stuff so that it ends up as the gnuradio.audio_oss module
 # This usually ends up at:
 #   ${prefix}/lib/python${python_version}/site-packages/gnuradio
@@ -34,10 +32,10 @@ EXTRA_DIST = run_tests.in
 TESTS = run_tests
 
 LOCAL_IFILES =                                 \
-       audio_oss.i                             
+       $(top_srcdir)/gr-audio-oss/src/audio_oss.i
 
 NON_LOCAL_IFILES =                     \
-       $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+       $(GNURADIO_I)
 
 ALL_IFILES =                           \
        $(LOCAL_IFILES)                 \
@@ -71,13 +69,14 @@ swiginclude_HEADERS =                       \
 
 _audio_oss_la_LIBADD =                         \
        $(PYTHON_LDFLAGS)               \
+       $(GNURADIO_CORE_LA)             \
        $(OSS_LIBS)                     \
        -lstdc++                                
 
 _audio_oss_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
 
-audio_oss.cc audio_oss.py: audio_oss.i $(NON_LOCAL_IFILES)
-       $(SWIG) $(SWIGPYTHONARGS) -module audio_oss -o audio_oss.cc $<
+audio_oss.cc audio_oss.py: $(LOCAL_IFILES) $(NON_LOCAL_IFILES)
+       $(SWIG) $(SWIGPYTHONARGS) -module audio_oss -o audio_oss.cc $(LOCAL_IFILES)
 
 # Don't distribute output of swig
 dist-hook: