Merged r11123:11148 from jcorgan/np into trunk.
[debian/gnuradio] / gr-audio-alsa / src / Makefile.am
index 8230ab56999dee5c0173765c0e6042b8cdf25e6e..ee7498af48b8a52ef16eb9797e7b63898cea9266 100644 (file)
@@ -23,10 +23,6 @@ include $(top_srcdir)/Makefile.common
 
 EXTRA_DIST = run_tests.in
 
-TESTS = run_tests
-
-DISTCLEANFILES = run_tests
-
 # C/C++ headers get installed in ${prefix}/include/gnuradio
 grinclude_HEADERS =                    \
        audio_alsa_sink.h               \
@@ -57,8 +53,11 @@ libgnuradio_audio_alsa_la_LIBADD =   \
 libgnuradio_audio_alsa_la_LDFLAGS =    \
        $(NO_UNDEFINED)
 
+if PYTHON
 ###################################
 # SWIG Python interface and library
+TESTS = run_tests
+DISTCLEANFILES = run_tests
 
 TOP_SWIG_IFILES =                      \
        audio_alsa.i
@@ -81,3 +80,4 @@ BUILT_SOURCES = $(swig_built_sources)
 
 # Do not distribute the output of SWIG
 no_dist_files = $(swig_built_sources)
+endif
\ No newline at end of file