Merged r6271:6278 from jcorgan/t182 into trunk. Implements ticket:182.
[debian/gnuradio] / gnuradio-examples / python / Makefile.am
index fa88a980ff1161d3d7e96926e7773ff3c19ad452..c9db48d6ab0453e3a4bc2ced0ec6f69a6e6d37b9 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
-SUBDIRS = audio digital_voice gmsk2 mc4020 multi_usrp usrp
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = \
+    apps \
+    audio \
+    digital_voice \
+    digital \
+    multi-antenna \
+    multi_usrp \
+    networking \
+    usrp \
+    hier \
+    ofdm
+
+# Make example scripts with #! executable
+install-data-local:
+       for i in `find $(exampledir) -type f ! -perm 755`; do \
+         if head -1 $$i | grep -q '^#!'; then \
+           chmod 755 $$i; \
+           echo "made executable: $$i"; \
+         fi; \
+       done