Adds usrp2 example directory, WFM receiver. Default audio rate works out to 32015...
[debian/gnuradio] / gnuradio-examples / python / Makefile.am
index fa88a980ff1161d3d7e96926e7773ff3c19ad452..079d5da60c94cdd20277241605fc711cf615e32d 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004 Free Software Foundation, Inc.
+# Copyright 2004,2007 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 # 
 # You should have received a copy of the GNU General Public License
 # along with GNU Radio; see the file COPYING.  If not, write to
-# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-# Boston, MA 02111-1307, USA.
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
 # 
 
-SUBDIRS = audio digital_voice gmsk2 mc4020 multi_usrp usrp
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = \
+       apps \
+       audio \
+       dect \
+       digital \
+       digital-bert \
+       digital_voice \
+       mp-sched \
+       multi-antenna \
+       multi_usrp \
+       network \
+       ofdm \
+       usrp \
+       usrp2
+
+# Make example scripts with #! executable
+install-data-local:
+       for i in `find $(exampledir) -type f ! -perm 755`; do \
+         if head -1 $$i | grep -q '^#!'; then \
+           chmod 755 $$i; \
+           echo "made executable: $$i"; \
+         fi; \
+       done