Merge commit 'v3.3.1' into try-3.3.1
[debian/gnuradio] / gnuradio-examples / c++ / dial_tone / Makefile.am
index 2a712ace820d8e1c59418521fe1cb9cb7950798a..188275fcaf43ab78cdbb1dc18bf6e412d7c68267 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2006 Free Software Foundation, Inc.
+# Copyright 2006,2008,2009,2010 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
 include $(top_srcdir)/Makefile.common
 
 # For compiling within the GNU Radio build tree
-INCLUDES=$(STD_DEFINES_AND_INCLUDES) \
-         -I$(top_srcdir)/gr-audio-alsa/src 
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/gr-audio-alsa/src \
+       $(STD_DEFINES_AND_INCLUDES) \
+       $(WITH_INCLUDES)
 
-GR_AUDIO_ALSA_LA=$(top_builddir)/gr-audio-alsa/src/libgr_audio_alsa.la
+GR_AUDIO_ALSA_LA=$(top_builddir)/gr-audio-alsa/src/libgnuradio-audio-alsa.la
 
 # For compiling outside the tree, these will get fished out by pkgconfig
 
 noinst_PROGRAMS = dial_tone
-    
+
 noinst_HEADERS = \
     dial_tone.h
-        
+
 dial_tone_SOURCES = \
     dial_tone.cc          \
     main.cc
@@ -41,5 +43,3 @@ dial_tone_SOURCES = \
 dial_tone_LDADD = \
     $(GNURADIO_CORE_LA) \
     $(GR_AUDIO_ALSA_LA)
-
-MOSTLYCLEANFILES = *~