Adding ability for FIR filter with internal buffer to decimate.
[debian/gnuradio] / gnuradio-core / src / tests / Makefile.am
index 01e35120f424149c8a49209e373ff97f9f70a3c8..2bf7cb4e546fc84d034a823224378b0bb0c38b12 100644 (file)
@@ -32,10 +32,12 @@ TESTS = test_all
 
 #Test program to test setting up buffers using gr_test which can be run manually
 EXTRA_DIST =                           \
-       test_buffers.py
+       test_buffers.py \
+       benchmark_dotprod
+
 
 noinst_PROGRAMS                =       \
-       benchmark_dotprod       \
+       benchmark_dotprod_fff   \
        benchmark_dotprod_fsf   \
        benchmark_dotprod_fcc   \
        benchmark_dotprod_scc   \
@@ -43,18 +45,25 @@ noinst_PROGRAMS             =       \
        benchmark_dotprod_ccf   \
        benchmark_nco           \
        benchmark_vco           \
+       test_all                \
        test_runtime            \
        test_general            \
-       test_all                \
        test_filter             \
        test_vmcircbuf
 
+#bin_PROGRAMS = \
+#      test_all
+
+
+noinst_SCRIPTS = \
+       benchmark_dotprod
+
 
 LIBGNURADIO =  $(GNURADIO_CORE_LA)
 LIBGNURADIOQA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core-qa.la $(LIBGNURADIO)
 
-benchmark_dotprod_SOURCES = benchmark_dotprod.cc
-benchmark_dotprod_LDADD   = $(LIBGNURADIO)
+benchmark_dotprod_fff_SOURCES = benchmark_dotprod_fff.cc
+benchmark_dotprod_fff_LDADD   = $(LIBGNURADIO)
 
 benchmark_dotprod_fsf_SOURCES = benchmark_dotprod_fsf.cc
 benchmark_dotprod_fsf_LDADD   = $(LIBGNURADIO)