Merged eb/gcell -r8215:8243 into trunk. This adds gr-gcell, the GNU
[debian/gnuradio] / gnuradio-core / src / python / gnuradio / gr / Makefile.am
index 557bf13f9d8ec60236f5a82ee539b95ecdc3af72..3d98bcd40f816111bd4f7020166d11ea5e992dff 100644 (file)
@@ -1,11 +1,11 @@
 #
-# Copyright 2004,2005,2006 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008 Free Software Foundation, Inc.
 # 
 # This file is part of GNU Radio
 # 
 # GNU Radio is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
+# the Free Software Foundation; either version 3, or (at your option)
 # any later version.
 # 
 # GNU Radio is distributed in the hope that it will be useful,
@@ -21,8 +21,9 @@
 
 include $(top_srcdir)/Makefile.common
 
-EXTRA_DIST = run_tests.in
-
+EXTRA_DIST =                   \
+       run_tests.in            \
+       test_16bit_1chunk.wav
 
 TESTS =                        \
        run_tests
@@ -32,16 +33,14 @@ grgrpythondir = $(grpythondir)/gr
 
 grgrpython_PYTHON =            \
        __init__.py             \
-       basic_flow_graph.py     \
        exceptions.py           \
-       flow_graph.py           \
        gr_threading.py         \
        gr_threading_23.py      \
        gr_threading_24.py      \
-       hier_block.py           \
        hier_block2.py          \
        prefs.py                \
-       scheduler.py            
+       scheduler.py            \
+       top_block.py
 
 noinst_PYTHON =                        \
        benchmark_filters.py            \
@@ -49,18 +48,19 @@ noinst_PYTHON =                     \
        qa_add_v_and_friends.py         \
        qa_agc.py                       \
        qa_argmax.py                    \
-       qa_basic_flow_graph.py          \
        qa_bin_statistics.py            \
        qa_cma_equalizer.py             \
        qa_complex_to_xxx.py            \
        qa_constellation_decoder_cb.py  \
        qa_correlate_access_code.py     \
+       qa_delay.py                     \
        qa_diff_encoder.py              \
        qa_diff_phasor_cc.py            \
+       qa_ecc_ccsds_27.py              \
        qa_feval.py                     \
+       qa_fft.py                       \
        qa_fft_filter.py                \
        qa_filter_delay_fc.py           \
-       qa_flow_graph.py                \
        qa_fractional_interpolator.py   \
        qa_frequency_modulator.py       \
        qa_fsk_stuff.py                 \
@@ -79,6 +79,7 @@ noinst_PYTHON =                       \
        qa_mute.py                      \
        qa_nlog10.py                    \
        qa_noise.py                     \
+       qa_ofdm_insert_preamble.py      \
        qa_packed_to_unpacked.py        \
        qa_pipe_fittings.py             \
        qa_pll_carriertracking.py       \
@@ -89,6 +90,7 @@ noinst_PYTHON =                       \
        qa_sig_source.py                \
        qa_single_pole_iir.py           \
        qa_single_pole_iir_cc.py        \
+       qa_skiphead.py                  \
        qa_unpack_k_bits.py